Skip to main content
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Upgrade Express "Install customer data" doesn't do anything


    • Product: Aleph
    • Product Version: 20, 21, 22, 23
    • Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care


    Problem Symptoms: 
    When "2. Install customer data" is selected in the Upgrade Express upgrade_util menu on the Target server, the proc executes in just a second. It doesn't give any error but doesn't actually do anything. See log in Additional Information. 


    In exporting the data from the Source server, "2. Pack the u-tree" was selected. (This is seen as "conf" in the /exlibris/aleph/upgrade_express_2101_2201/logs/log.yyyymmdd.nnnnn/create_customer_data.log): 

    Archiving Unix data : ext01 mon01 mon10 mon11 mon12 mon30 mon50 mon60 pwd00 
    Starting util/oracle_exp_aleph_libs_a. conf_or_data: conf <---- 

    But when the "Install customer data" was performed on the Target server "1. Install Oracle data" was selected. Since there *was* no Oracle data (since it had not been exported), there was nothing for the proc to do. 


    As suggested in Jerry Specht's "ACTUAL Run" Upgrade Express documents to *always* select "3" (Both) in doing the export and import (-- unless this is a refresh of the Oracle data at the time of cutover to the new version -- in which case do "Oracle data only").


    Additional Information

    Install customer data log:

    start : oracle_imp_aleph_libs_a at 2014-07-21 19:02

    Mon Jul 21 19:02:46 EST 2014

    Import ended
    end : oracle_imp_aleph_libs_a at 2014-07-21 19:02


    • Article last edited: 28-Feb-2016