Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Upgrade Express 16 - 17: "DBI module is not installed - you cannot run the kit"

    • Article Type: General
    • Product: Aleph
    • Product Version: 16.02

    Description:
    I am getting the message "The DBI module is not installed - you cannot run the kit" when I try to run Upgrade Express 16.02 to 17.01.

    Also, when I try to close oracle server with uitl o/1/2, I get the message "ORA-01031: insufficient privileges" for the aleph_dba user.

    Resolution:
    There was a problem with your tnsnames.ora file, with the service definition. I fixed that and saved the previous as tnsnames.ora.101606 .

    It is ok now:
    Check Upgrade Environment
    =========================

    The environment contains all of the needed modules and libraries

    +----------------------------------------------------------+
    | Upgrade Express Utility 16.02 -> 17.01 Version 1.16 |
    +----------------------------------------------------------+

    0. Exit
    1. Define Upgrade Parameters
    2. Check Environment
    3. Run Upgrade Express
    4. Backup/Restore Oracle Tables to be Upgraded
    5. View/Restore Previously Stored Configuration Files
    6. View Logfiles
    7. Perform Post Upgrade Express Actions

    Please select [0]:


    • Article last edited: 10/8/2013
    //Feedback