Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Upgrade Express 18-19: step 1014: An error has occured while upgrading z107

    • Article Type: General
    • Product: Aleph
    • Product Version: 20

    Description:
    We are getting an error message on step 1014 of the 18-19 Upgrade Express.

    Step 1014 - Description:

    Course-Reading library - moved Z107 table from the PW library to all ADM libraries.

    *******************************************************************
    Step begin 1014
    ...
    ...
    The z107 table's old version is in z107_old

    creating new table: abc50
    ...
    ...
    Enter value for 2:
    SP2-0546: User requested Interrupt or EOF detected.
    Disconnected from Oracle Database 11g Enterprise Edition Release 11.1.0.7.0 - 64bit Production
    ...
    ...
    abc50.Z107
    *
    ERROR at line 2:
    ORA-00942: table or view does not exist
    ...
    ...
    A_ERROR: An error has occured while upgrading z107 in abc50. Rolling back.
    ...
    ...
    Rollback done.
    Step end 1014

    The v18 $pw_library has a z107 table, but it is empty (no records). We do not have Course Reading.

    Resolution:
    Since you are not using Course Reserves, this error can be ignored.

    It should, however, have been able to define a z107 table in the abc50 ADM library. I *believe* that the failure to do so may have had to do with the fact that there is no entry for z107 in the v20 abc50 $data_root/file_list and the fact that the abc50 $data_root/prof_library has:

    setenv file_list_type USR

    This is incorrect. If a library is both an ADM library and the $usr_library, it needs to specify:

    setenv file_list_type ADM


    • Article last edited: 10/8/2013