Skip to main content
ExLibris

Knowledge Assistant

BETA
 
  • Subscribe by RSS
  • Back
    Aleph

     

    Ex Libris Knowledge Center
    1. Search site
      Go back to previous article
      1. Sign in
        • Sign in
        • Forgot password
    1. Home
    2. Aleph
    3. Knowledge Articles
    4. Wrong item is returned (and has in-transit slip produced) in GUI Circ

    Wrong item is returned (and has in-transit slip produced) in GUI Circ

    1. Last updated
    2. Save as PDF
    3. Share
      1. Share
      2. Tweet
      3. Share
    1. Additional Information
    • Article Type: General
    • Product: Aleph
    • Product Version: 20

    Problem Symptoms:
    When item barcode 31225008098325 was checked in, rather than returning that item, the system returned (and produced a transit slip for) item barcode 2119693-10.

    (A second check-in of item barcode 31225008098325 *was* successful.)

    Why the erroneous return?

    Cause:
    1. The barcode was incorrectly scanned (as null) and
    2. the xxx50 tab100 had no ITEM-BARCODE-OR-CALL-NO line -- and "Y" is the default.

    Resolution:
    Assuming that the library doesn't actually type in call numbers to loan items which lack a barcode ...

    1. Add the following line to the xxx50 tab100:

    ITEM-BARCODE-OR-CALL-NO=N

    or, if it already exists with "=Y", change it to "=N"

    2. Restart the pc_server.

    After which, a the server will respond with a message indicating that an invalid barcode was scanned in when the scanner sends a null or 1-character value to the server.

    Additional Information

    The following SQL's show the z30_rec_key's of the two items:

    xxx50@ALEPH20> select z30_rec_key from z30 where z30_barcode = '31225008098325';
    **** Hit return to continue ****

    Z30_REC_KEY
    ---------------
    000670736000010

    xxx50@ALEPH20> select z30_rec_key from z30 where z30_barcode = '2119693-10';
    **** Hit return to continue ****

    Z30_REC_KEY
    ---------------
    002119693000010


    ITEM-BARCODE-OR-CALL-NO is a value in the ADM tab100. From the tab100 header:

    ! This switch is relevant for the Item Bar of the Circulation module
    ! and for item retrieval during self check.

    The xxx50 tab100 has no specification; the default is "Y". (Y = Item retrieval by call number is enabled.)

    Item 2119693-10 has no call number:

    02 z30_call_no ................. <-- null

    The following SQL shows items with a null z30_call_no:

    xxx50@ALEPH20> select z30_rec_key from z30 where z30_call_no is null;
    **** Hit return to continue ****

    Z30_REC_KEY
    ---------------
    002119693000010 <----
    002119829000010
    002119832000010
    002119839000010
    000005002000010
    000537847000020
    <etc.>

    Note that the very first z30_rec_key retrieved is that of the item which the system erroneously returned. Just as the above SQL finds 2119693-10 as the first item with a null barcode, so the Circ return program finds (and uses) it.

    The same problem in *loaning* items (check-out) is described in Articles 000023257 and 000018141.

    Category: Circulation (500)

    Subject: Returns


    • Article last edited: 5/27/2014
    View article in the Exlibris Knowledge Center
    1. Back to top
      • Wrong file name format generated for EDI claims to Harrassowitz?
      • Wrong items in report of Items in High Demand (cir-14)
    • Was this article helpful?

    Recommended articles

    1. Article type
      Topic
      Language
      English
      Product
      Aleph
    2. Tags
      1. 20
      2. Circulation (500)
      3. contype:kba
      4. Prod:Aleph
      5. Returns
      6. Type:General
    1. © Copyright 2025 Ex Libris Knowledge Center
    2. Powered by CXone Expert ®
    • Term of Use
    • Privacy Policy
    • Contact Us
    2025 Ex Libris. All rights reserved