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    Analytics library filter not working correctly

    • Article Type: General
    • Product: Alma

    Problem Symptoms:
    In Analytics, in creating are report, filter by Library does not work for some libraries.
    If I create the report without library filter I can see results for the Main library in the report output.
    But if I filter for the Main library, I get no results.

    Cause:
    In ALMA menu > General Configuration > Libraries > Add a Library or Edit Library Information you can see that for the Main Library, the Organization Unit Name has a blank after ?€˜Main?€™! But when selecting the 'Main' library in the Edit Filter screen by checking the checkbox, the blank is removed by OBI. When you convert the filter to SQL and insert a blank manually, so that you filter by 'Main ', you successfully get results for the Main library.

    Resolution:
    Please go to ALMA menu > General Configuration > Libraries > Add a Library or Edit Library Information > Main Library and remove the blank in the Organization Unit Name field after ?€˜Main ?€™.
    Then wait until after the next ETL has run and you should successfully get results for the Main library also when selecting the 'Main' library in the Edit Filter screen by checking the checkbox.