Unable to retrieve loan and request info from My Account error 403
- Product: Alma
- Product Version: May 2016 Release
- Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care
Problem Symptoms
When user signs into Primo and attempts to retrieve loans and requests information from "My Account", Primo displays the following error: "an unrecoverable problem was detected trying to call the ILS system".
The following error displays in the FE library server log:
ERROR [t-ILSG-pool-22-thread-15] [c-ILSDefaultAdaptor] - Http exception when calling ILS: with status code:'403' ; error:Method failed: HTTP/1.1 403 Forbidden
Cause
1. The target server (Alma) is blocking the source server (Primo) or the PDS server on relevant port;
2. The Primo/PDS IP is not configured to be allowed on an application level in Alma.
2. The Primo/PDS IP is not configured to be allowed on an application level in Alma.
Resolution
Report about error to Alma Support via SalesForce case.
- Article last edited: 06-May-2016