Skip to main content
Ex Libris Knowledge Center

Back Office returns 404 after restart

  • Article Type: General
  • Product: Primo
  • Relevant for Installation Type: Dedicated-Direct; Direct; Local; Total Care

Problem Symptoms:
* Running be_start completes successfully by reporting "Done"
* Back Office returns a 404 error for all http requests
* BE log has error "Cannot resolve reference to bean 'wildebeastService' while setting bean property 'wildebeastService';"
* be_conf directory contains a search.properties file sized 0 bytes or search.properties is missing

Cause:
The search.properties file can be deleted when the Primo Back Office is stopped incorrectly

Resolution:
Run the following commands on the Back Office server:
1) be_stop
2) be_bin
3) ./set_globals.sh
4) be_start

Additional Information

Running this resolution cannot hurt the Primo system. It can be run multiple times without issue.

Category: BO monitoring

Subject: Dashboard


  • Article last edited: 10/8/2014