Skip to main content
ExLibris

Knowledge Assistant

BETA
 
  • Subscribe by RSS
  • Back
    Primo

     

    Ex Libris Knowledge Center
    1. Search site
      Go back to previous article
      1. Sign in
        • Sign in
        • Forgot password
    1. Home
    2. Primo
    3. Knowledge Articles
    4. Backup Package: Primo software backup (p4): error message "tar: [...] file changed as we read it"

    Backup Package: Primo software backup (p4): error message "tar: [...] file changed as we read it"

    1. Last updated
    2. Save as PDF
    3. Share
      1. Share
      2. Tweet
      3. Share
    1. Additional Information
    • Article Type: General
    • Product: Primo

    Problem Symptoms:
    The following error messages appear in the log file of the Primo software backup (/exlibris/backup/logs/prd_software_p4_Detail_<date>_<time>.log):

    tar: exlibris/primo/p4_1/log/pds_server.log: file changed as we read it
    tar: exlibris/primo/p4_1/primoe/apache/logs/access_log_ssl: file changed as we read it
    [...]

    Cause:
    The contents of the file mentioned in the error message "tar: [...] file changed as we read it" were modified while the program tar was backing up the file. The error message warns that the backup of the file may be inconsistent.

    When this message appears during a backup of an Ex Libris product it usually refers to log files. Therefore it is safe to ignore the message.

    Resolution:
    Make the Primo software backup (p4) use the command tar with the additional option "--warning=no-file-changed". This option will suppress the error message "tar: [...] file changed as we read it".

    In order enable the tar option "--warning=no-file-changed" please carry out the following steps:

    (1)
    Check the version of tar which the Ex Libris Backup Package uses by entering the following command as UNIX user primo:

    $ tar --version

    If this command reports the version "tar (GNU tar) 1.23" or a higher version then proceed to the next step.

    Otherwise STOP. The solution described in this Article is not applicable.


    (2)
    Change line 8 of the script /exlibris/backup/scripts/primo_software

    from:
    tar -cvf - $files_no_slash | $GZIPEX | split -b2000m - ${DEVICE}.gz_

    to:
    tar -cvf - --warning=no-file-changed $files_no_slash | $GZIPEX | split -b2000m - ${DEVICE}.gz_


    (3)
    Start the Primo software backup (p4) again.

    Additional Information

    The general option --warning=<keyword> was introduced with GNU tar version 1.23. The Ex Libris Backup Package uses the program /exlibris/product/util/bin/tar which is an executable file of GNU tar. The current version of GNU tar provided by Ex Libris as a 3rd-party product is 1.26 (10 December 2014).


    • Article last edited: 12/10/2014
    View article in the Exlibris Knowledge Center
    1. Back to top
      • Backup Package: backup p7 fails with error message "/bin/bash:: Too many arguments"
      • Backup Package: Primo software backup (p4): error message "tar: [...] File removed before we read it"
    • Was this article helpful?

    Recommended articles

    1. Article type
      Topic
      Community Content Type
      How To
      Content Type
      Knowledge Article
      Language
      English
    2. Tags
      1. contype:kba
      2. Prod:Primo
      3. Type:General
    1. © Copyright 2025 Ex Libris Knowledge Center
    2. Powered by CXone Expert ®
    • Term of Use
    • Privacy Policy
    • Contact Us
    2025 Ex Libris. All rights reserved