Skip to main content
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    IA Book Reader Deployment failed after 4.0 upgrade

    • Article Type: General
    • Product: Rosetta
    • Product Version: 4

    Problem Symptoms:
    IA Book Reader Deployment failed after 4.0 upgrade

    Bug solved

    1. Download the war again from Github :

    2. Redeploy (dps_stop dps_start)

    Additional Information

    * It is recommended to deploy the viewer on an external application server, as Ex Libris cannot guarantee future changes to the Rosetta JBoss AS will be compatible with the viewer.

    * If changes have been made to the *.war it can be modified to fit the updated version as follows by removing the two problematic files::
    - Inside the *.war under WEB-INF/lib is the dps-sdk-3.1.0.jar
    - Inside the *.sdk under comexlibriscoredaoejb3 remove the following two files:

    * IA book Reader Documentation:

    Category: Administration

    Subject: Plugin

    • Article last edited: 3/3/2015