Manage Processes is unreachable
- Article Type: General
- Product: Rosetta
- Product Version: 3
Problem Symptoms:
1. When in the Back Office, navigating to "Data Management"->"Manage Processes" results in home page, and processes page not being loaded.
2. Alternately, When in "Data Management"->"Monitor Process History", and then clicking on "Data Management"->"Manage Processes", results in an empty list, and error "For input string: "*"".
Cause:
This is caused by a bug when editing the schedule of a process; Changing it directly from Daily to Once.
This causes "*" to be inserted in the cron column, resulting in an error when trying to read from that column (which is what happens when navigating to "Data Management"->"Manage Processes".
Resolution:
1. Connect to the DB ros schema: s+ ros00
2. Run the following sql command:
update HPAPROCESS set SCHEDULER_APPLICATION_ID = 7, SCHEDUALING_EXPRESSION = null where SCHEDULER_APPLICATION_ID = 1 and SCHEDUALING_EXPRESSION like '%*%';
commit;
Additional Information
This bug was reported, and can be tracked in Jira: DPS-1235
Category: Back Office
Subject: Process Automation
- Article last edited: 3/2/2014