Out of memory error when indexing IE
- Product: Rosetta
- Product Version: 6.2
Symptoms
1. IE is in the index exception queue (failed to index)
2. The following message appears in the server log:
ERROR [com.exlibris.core.infra.svc.impl.resourcemanagement.JobReceiver] (INDEX_QUEUE Queue Job Receiver 125) [] Error during INDEX_QUEUE Queue Job Receiver execution
ERROR [com.exlibris.core.infra.svc.impl.resourcemanagement.JobReceiver] (INDEX_QUEUE Queue Job Receiver 125) [] java.lang.OutOfMemoryError
Cause
During a bagit deposit, IEs with many files could cause out of memory error due to the source metadata indexing work.
If under Deposits > Content Structure > Bagit, the 'Store Tags as Source Metadata' option is checked, for many tags the indexing job could take a lot of memory.
Resolution
1. Under Deposits > Content Structure > Bagit, uncheck 'Store Tags as Source Metadata'.
2. Remove the source MD file and re-index the IE
- Article last edited: 13-APR-2020