Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Error in RSI Log When Running RSI Index Build

    • Article Type: General
    • Product: SFX
    • Product Version: 4

    Description:
    Logged in as sfxglb41 and went into server admin util to run option 11-1 (build the RSI index) after we realised we hadn't done a build since the migration to SFX 4.
    Here's the output - looks like there might be a table missing?

    2010/10/09 15:20:55 Begin preparation: creating tables,checking consortia.
    2010/10/09 15:20:55 Build RAPID_SERVICE_INDICATOR_TEMP table.
    2010/10/09 15:20:55 Check for consortia records...
    2010/10/09 15:20:55 Consortia was not detected.
    2010/10/09 15:20:55 Consortia check done.
    2010/10/09 15:20:55 Build RAPID_SERVICE_INDICATOR table...
    2010/10/09 15:20:55 Preparation done.
    2010/10/09 15:20:55 Fetch active portfolios...
    2010/10/09 15:20:55 Working on institute:Default...
    [Sat Oct 9 15:20:55 2010] rsi_index_builder.pl: DBD::mysql::st execute failed: Table 'sfxglb41.LCL_SERVICE_INVENTORY' doesn't exist at /exlibris/sfx_ver/sfx4_1/sfxglb41/lib/IOL/Base.pm line 139.
    2010/10/09 15:20:55 could not upload protfolios to table RAPID_SERVICE_INDICATOR_TEMP
    2010/10/09 15:20:55 Done uploading records to RAPID_SERVICE_INDICATOR_TEMP.
    2010/10/09 15:20:55 Rename RAPID_SERVICE_INDICATOR_TEMP_BUILD RAPID_SERVICE_INDICATOR_TEMP.
    2010/10/09 15:20:55 Add index to RAPID_SERVICE_INDICATOR_TEMP...
    2010/10/09 15:20:55 Receive active portfolios from RAPID_SERVICE_INDICATOR_TEMP...
    2010/10/09 15:20:55 Upload active portfolios to RAPID_SERVICE_INDICATOR...
    2010/10/09 15:20:55 Done uploading active portfolios to RAPID_SERVICE_INDICATOR.
    2010/10/09 15:20:55 Add index to RSI...
    2010/10/09 15:20:55 Rename RAPID_SERVICE_INDICATOR_BUILD RAPID_SERVICE_INDICATOR...
    2010/10/09 15:20:55 Done uploading records to RAPID_SERVICE_INDICATOR.
    2010/10/09 15:20:55 Done building RSI.

    Resolution:
    The happened because you were logged in to global instance (sfxglb41) instead of a local one.


    • Article last edited: 10/8/2013
    //Feedback