Blank record display in WebVoyage when charged to status patron
- Product: Voyager
Problem Symptoms
- Click on record or open record from Permalink and record display is blank.
- Item is charged to a status patron (patron that belongs to a Status Patron Group)
Cause
Item is charged to a status patron (patron's Patron Group has "Display OPAC Messages for charged Items" in System Administration > Circulation > Patron Groups), but the Status Patron Group messages have not been configured in WebVoyage.
Resolution
Configure Status Patron Group messages in WebVoyage.
- Connect to server via SSH or telnet.
- cd /m1/voyager/xxxdb/tomcat/vwebv/context/vwebv/ui/{your skin}
- Open webvoyage.properties for editing and find this section:
###############################################################################
#
# Status Patron Groups messages for display on title and holdings pages
#
###############################################################################
page.searchResults.titles.statusPatronGroup.GROUPCODE=Message for title page
page.myAccount.chargedItem.item.statusPatronGroup.GROUPCODE=Message for holdings charged item
page.myAccount.reqPending.item.statusPatronGroup.GROUPCODE=Message for holdings with request pending
- Use Patron Group Code (from System Administration) in place of GROUPCODE and customize messages to right of equal (=) sign.
- Copy three message lines and repeat step 4 for every Status Patron Group.
- Save changes.
- Article last edited: 27-Dec-2017