Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Call slip request prevents deletion of bib record.

    • Article Type: General
    • Product: Voyager
    • Product Version: all

    Problem Symptoms:


    "Unable to delete bibliographic record. An outstanding call slip exists."  error message when attempting to delete bib record; associated call clip request was previously filled.
     


    Cause:


    The Archive period set in SysAdmin>Call Slips>Queues has not passed.



    Resolution:


    1. Shorten archive period, OR Wait for the archive period to pass1
    2. Run circjob 8 or circjob 12.

     

    Additional Information:

     

    1The following Prepackaged Reports Access query prompts you for a bib ID, and then identifies the title.  If the bib has a call slip, it also gives you the archive interval from your System Administration settings and tells you when the call slip will be archived, allowing the bib record to be deleted.

    SELECT DISTINCT BIB_TEXT.BIB_ID, BIB_TEXT.TITLE_BRIEF, CALL_SLIP.STATUS_DATE, 
    CALL_SLIP_PRINT_GROUP.ARCHIVE_PERIOD, 
    CALL_SLIP_PRINT_GROUP.ARCHIVE_INTERVAL, IIf([call_slip].[call_slip_id] Is 
    Null,"Now",DateAdd([archive_interval],[status_date],[archive_period]+1)) AS BibFreeOn
    FROM (CALL_SLIP RIGHT JOIN BIB_TEXT 
    ON CALL_SLIP.BIB_ID = BIB_TEXT.BIB_ID) LEFT 
    JOIN CALL_SLIP_PRINT_GROUP ON CALL_SLIP.PRINT_GROUP_ID = 
    CALL_SLIP_PRINT_GROUP.GROUP_ID
    WHERE (((BIB_TEXT.BIB_ID)=[Enter bib ID:]));

    Constructing custom SQL queries by request and troubleshooting unexpected results from customer-created SQL queries falls outside the scope of Support. The above has been posted for informational purposes.  Voyager-L and Developer Network are useful resources for finding helpful custom SQL or obtaining assistance from peers in troubleshooting custom queries.

     

     


    • Article last edited: 07-Oct-2022
    • Was this article helpful?