Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    GDC log stops at Transform step

    • Article Type: General
    • Product: Voyager
    • Product Version: 8.0.0

    Problem Symptoms:
    * Submit Data Change job and log stops at transform step:
    INFO - Start Transforming records...
    INFO - Transform 1 Elapsed Time: 00:00:00
    * Check jobd.log.<date> under /m1/voyager/xxxdb/log and see error logged:
    2013-02-14 10:56:28,243 28303916 [main] ERROR com.exlibris.voyager.jobd.JobExecutor - Job Failed to run properly: Unable to find com.exlibris.voyager.model.Library with id 0

    Cause:
    One of the locations in database does not have required Owning Library selected. Please note: any location in the database can cause the error, even if it is not used in any of the records affected by the GDC transaction.

    Resolution:
    1. Open System Administration > System > Locations.
    2. Highlight affected location.
    3. Click Edit.
    4. Select an Owning Library from drop-down.
    5. Save.

    Additional Information

    If not sure which location is missing Owning Library, query LOCATION table: select * from LOCATION where LIBRARY_ID=0;

    Category: Global data change (GDC)


    • Article last edited: 10/8/2013