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    Hourly loans charged after midnight calculate due time when library closed

    • Article Type: General
    • Product: Voyager
    • Product Version: 9

    Problem Symptoms:
    * For transactions where
    ** Count Closed Days/Hours/Minutes for Loan not checked in Circulation Policy
    ** Apply Fixed Due Time not checked in Circulation Policy
    ** no Overnight Loan In Effect or Due Time in Calendar
    ** charged after midnight
    the due time calculates per matrix, rather than applying remaining loan period after close time to following day.

    Cause:
    This behavior is the result of VYG-6270.

    Resolution:
    Issue VYG-6270 is currently in Development.

    Additional Information

    Replication steps:
    1. Set up System Administration > Circulation with the following:
    1.a. Calendars > Calendar set to open in a.m. and close in a.m.
    1.b. Do not fill in Overnight Loan In Effect or Due Time.
    1.c. Policy Definitions > Policies > uncheck boxes for
    1.c.i. Count Closed Days/Hours/Minutes for Overnight Loans
    1.c.ii. Count Closed Days/Hours/Minutes for Fine
    1.c.iii. Apply Fixed Due Time For Overnight Loan
    1.d. Policy Definitions > Matrix > Find matrix entry for hourly loan.
    2. In Circulation, charge item to patron where item type & patron group fit matrix from step 1.d.
    3. If charge occurs before midnight, remaining loan period after Close Time will roll into next day, as expected.
    4. If charge occurs after midnight, due time will be 3 hours from charge time, when library is closed.

    Workaround: Manually update due time for hourly loans charged after midnight.

    Example:
    * Calendar: Open Time: 10:00 AM / Close Time 2:00 AM
    * 3 hour loan period
    Charge item at 11:50 PM. Due following day at 10:50 AM
    Charge item at 12:15 AM. Due at 3:15 AM

    Category: Circulation - Voyager

    Subject: Voyager


    • Article last edited: 10/21/2014