MS: Blocked when booking equipment
- Article Type: General
- Product: Voyager
- Product Version: 8.2.1
Problem Symptoms:
* Patrons are blocked when placing Media equipment bookings if no matrix exists. And, for some workflows, bookings are blocked when a matrix does exist.
* Receive message: "Requester is not authorized to book equipment of type "
Cause:
This behavior is a result of Issue 16384-22401 / VYG-2499.
Resolution:
Issue VYG-2499 is fixed for Voyager 9.0.0 and higher.
Additional Information
Replication steps:
Patron Barcode KIT (Patron Group=Staff)
Example 1.
Media System Administration > Media Scheduling > Policy Groups > Matrices? > no matrix selected for Staff/AV Cart:
{All}/{All} Matrix allows bookings.
Workflow 1:
Select Add... > Equipment > AV Cart
Select specific Equipment item
Double click OR
Click on blue arrow to select specific item
Receive "Requester is not authorized to book equipment of type AV Cart." error message.
Workflow 2:
Equipment Number or Barcode > enter Barcode.
Select add by barcode
Receive "Requester is not authorized to book equipment of type ." error message.
Workflow 3:
Select Add Type... > Equipment > CD Player > OK
Receive "Requester is not authorized to book equipment of type AV Cart." error message.
Workflow 4:
In WebVoyage > Media Equipment Booking
Select AV Cart
Click Submit
Receive "The selected equipment cannot be picked up or delivered. Please select a different piece of equipment from the list." error message.
Example 2
Media System Administration > Media Scheduling > Policy Groups > Matrices? > matrix selected for Staff/CD Player allows bookings.
Workflow 1:
Select Add... > Equipment > CD Player
Select specific Equipment item
Double click OR
Click on blue arrow to select specific item
Equipment is added without error.
Workflow 2:
Enter Barcode
Select add by barcode
Receive "Requester is not authorized to book equipment of type ." error message
Workflow 3:
Select Add Type... > Equipment > CD Player > OK
Equipment is added without error.
WebVoyage allows bookings without error.
Workaround:
Create specific matrix for Item Type / Patron Group combination and use workflow 1, 3, or create bookings via WebVoyage.
Category: (Voy Media Scheduling)
- Article last edited: 3/28/2014