Operator gets 'Failed to load security profile' error when logging into System Administration
- Product: Voyager
- Product Version: 9
Problem Symptoms
Upon logging into System Administration, operator receives error message: "Failed to load security profile."
Cause
User is not associated with a Master Profile.
Resolution
To resolve this error and grant SysAdmin access to operator, perform the following steps:
- System Administration > Security > Operator Profiles, choose Operator Profile; click Edit
- Click Current Profiles tab; verify user is not associated with an entry with ID type of 'Master'; click Cancel
- SysAdmin > Security > Master Profiles, choose appropriate Master Profile; click Edit
- On Operator tab, move Operator from Available Operators to Selected Operators column
- On Profile Values and Locations tabs, ensure proper options are selected; Save
Additional Information
Master Security Profiles (such as "Backup Administrator") control access to the System Administration module. Sites have limited ability to modify the System Administrator operator (aka: SYSADMIN) because it is a critical account. Sites are strongly encouraged to share their SYSADMIN operator account password with Ex Libris so that it can be documented. This account is also extremely useful for troubleshooting. Operators are linked to a Master Security Profile (such as "Backup Administrator") so that they can perform Security, System-wide Configuration, Policy Group Configuration, and other essential tasks.
See the "Master Security Profiles - Creating, Editing, and Deleting" section in Chapter 9 of the System Administration User's Guide.
- Article last edited: 10/4/2019