SELF: Patrons not blocked in Patron Information Response (64) message
- Article Type: General
- Product: Voyager
- Product Version: 8.1.1
Problem Symptoms:
? Selfcheck allows ineligible patrons to charge items.
? Patrons are not blocked from charging via selfcheck when expired patrons, max recalled items overdue, max self-shelved items, max lost items, and max recalls blocks apply.
? If the same charge transactions are attempted using the Voyager Circulation Client the expected ?patron blocked? message appears
Cause:
This behavior is a result of Issue 16384-18529.
Resolution:
Issue 16384-18529 is fixed for Voyager 8.1.2.
If you are on Voyager 8.1.1 and are experiencing this bug, please submit an Incident via the eService and ask for the fix to Issue 16384-18529. Support can apply the fix for you.
If you are not on Voyager 8.1.1, you will need to upgrade to 8.1.1 before you can get this fix.
Additional Information
For the Expired patrons, Max recalled items overdue, Max Self shelved items and Max Lost items blocks, SelfCheck should send Charge Privileges Denied, Renewal Privileges Denied, Recall Privileges Denied, and Hold Privileges Denied. For Max recalls, the SelfCheck should send Recall Privileges Denied only. Table 5-16 of the SysAdmin User?s Guide outlines the blocks and which privileges should be denied.
Replication steps:
1. In Circulation, apply any of these blocks to the patron record: Expired patrons, Max recalled items overdue, Max Self shelved items, Max Lost items, and Max recalls
2. Send the Patron Information (63) message to Voyager SelfCheck.
3. In the Patron Information Response (64) message, the Patron Status field does not reflect any Charge Privileges Denied, Renewal Privileges Denied, Recall Privileges Denied, or Hold Privileges Denied where appropriate. This would be with a Y in positions 0, 1, 2, and 3.
4. The 9 and 12 positions do accurately reflect ?Too many items lost? and ?Recall Overdue.?
Workaround: None.
Category: Circulation
- Article last edited: 10/8/2013