"The IBM Cognos gateway is unable to connect to the IBM Cognos BI server" when trying to login to ARC
- Product: ARC, Aleph
- Product Version: 2, 3, 4
- Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care
Description
When trying to connect to the ARC portal you get the error message
"The IBM Cognos gateway is unable to connect to the IBM Cognos BI server. The server may be unavailable or the gateway may not be correctly configured.
Try again or contact your administrator.'
CASE 1:
arc_startup with error:
"Starting up slapd-ram9...
Server not running!! Failed to start ns-slapd process."
In the log slapd, we have an error message:
cd /exlibris/crn/SunOne/slapd-ram9/logs/errors
[11/Jul/2016:15:08:23 +0200] - ERROR<4612> - Startup - conn=-1 op=-1 msgId=-1 - Unable to start slapd because it is already running as process 7925
[11/Jul/2016:15:08:23 +0200] - ERROR<12302> - Bootstrap config - conn=-1 op=-1 msgId=-1 - System error Shutting down due to possible conflicts with other slapd processes
CASE 2:
arc_startup without error
In the log Cognos, we have an error message:
cd /exlibris/crn/arc2_1/c8/logs/cogconfig_response.csv
ERROR, "[main]", "The configuration data is locked by another instance of IBM Cognos Configuration."
Resolution
CASE 1:
Cause:
A file lock (number of process 7925) has been created
Solution:
After deleting a file named "lock" in the /slapd-ram9>/locks directory, the directory server started.
CASE 2:
Cause:
When you start IBM Cognos Configuration, it checks to see if the cogstartup.lock file exists in c10_location/configuration. The file may exist if a previous instance did not shut down properly or if another instance of IBM Cognos Configuration is running.
Solution:
delete the cogstartup.lock file in c10_location/configuration
Additional Information
Example CASE 1:
crn@arcserver(arc2_1)locks/server$pwd
/exlibris/crn/SunOne/slapd-ram9/locks/server
crn@arcserver(arc2_1)locks/server$ll
total 0
-rw-rw-r-- 1 crn exlibris 0 Jun 7 21:27 7925
After deleting file “7925” in directory /exlibris/crn/SunOne/slapd-ram9/locks/server and restarted arc, the problem has been resolved.
See also link at IBM support
http://www-01.ibm.com/support/docview.wss?uid=swg21333236
Example CASE 2:
arc-arc2_1(USMR0)$pwd
/exlibris/crn/arc2_1/c8/configuration/
arc-arc2_1(USMR0)$ll
-rw-rw-r-- 1 crn exlibris 0 Aug 2 14:37 cogstartup.lock
After deleting file “cogstartup.lock” in directory /exlibris/crn/arc2_1/c8/configuration/ and restarted arc, the problem has been resolved.
See also link at IBM support
An article with the same error but different cause can be found here: Error message when trying to login to ARC: The IBM Cognos gateway is unable to connect to the IBM Cognos BI server
- Article last edited: 13-July-2016