Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Aleph 22: AIK Step 3.3 fails with error message "ERR: Oracle software versions are different on the target and source servers"

    • Article Type: General
    • Product: Aleph

    Problem Symptoms:
    When one executes Step 3.3 "Install database" of the Aleph 22 Installation Kit on a server where Aleph 21 already exists, the following error message appears:

    "ERR: Oracle software versions are different on the target and source servers"

    Cause:
    (1)
    Since Aleph 21 has been installed on the server, the Oracle 11.2.0.3 software exists in the directory /exlibris/app/oracle/product/11r2 on that server.


    (2)
    The Aleph 22 Installation Kit includes the files of the Oracle database for Aleph 22. This database has version 11.2.0.4.


    (3)
    AIK Step 3.3 compares the version of the Oracle software installed in directory /exlibris/app/oracle/product/11r2 with the version of the database files included in the AIK 22.

    If those versions do not match (11.2.0.3 vs. 11.2.0.4), then AIK Step 3.3 returns the following error message:

    "ERR: Oracle software versions are different on the target and source servers"



    Root cause:
    -----------
    (1)
    Aleph 21 is certified with Oracle versions 11.2.0.3 and 11.2.0.4.
    The Aleph 21 Installation Kit installs Oracle 11.2.0.3.
    After the installation one has the option to upgrade Oracle to version 11.2.0.4.

    Aleph 22 is certified with Oracle version 11.2.0.4.


    (2)
    The Aleph 21 Installation Kit installs Oracle 11.2.0.3 in the directory /exlibris/app/oracle/product/11r2.
    The Aleph 22 Installation Kit installs Oracle 11.2.0.4 also in the directory /exlibris/app/oracle/product/11r2.

    When one tries to install Aleph 22 on a server where Aleph 21 already exists, then Step 3.1 "Extract Oracle software" of the AIK 22 detects the directory /exlibris/app/oracle/product/11r2 and returns the following message:

    "Oracle software already exists on the server"


    Conclusion:
    ===========
    It is not possible to install the Oracle versions 11.2.0.3 and 11.2.0.4 in parallel on an Aleph server.

    Resolution:
    (1)
    Upgrade the Oracle software and the database of Aleph 21 from version 11.2.0.3 to 11.2.0.4, following the instructions in the document "How to Upgrade Oracle Software and Database from Oracle Version 11.2.0.3 to 11.2.0.4" (Ex Libris Documentation Center: Cross-Product > Technical Documentation > Oracle > Oracle 11g).

    (2)
    Continue the installation of Aleph 22 with the following Steps of the Aleph Installation Kit:

    Step 3.2 "Create listener.ora and tnsnames.ora file"
    Step 3.3 "Install database"


    • Article last edited: 3/3/2015
    //Feedback