Skip to main content
ExLibris

Knowledge Assistant

BETA
 
  • Subscribe by RSS
  • Back
    Aleph

     

    Ex Libris Knowledge Center
    1. Search site
      Go back to previous article
      1. Sign in
        • Sign in
        • Forgot password
    1. Home
    2. Aleph
    3. Knowledge Articles
    4. GUI crashes with message "ALEPH Catalog has stopped working"

    GUI crashes with message "ALEPH Catalog has stopped working"

    1. Last updated
    2. Save as PDF
    3. Share
      1. Share
      2. Tweet
      3. Share
    No headers

     

    • Product: Aleph
    • Product Version: 20, 21, 22, 23
    • Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care

     

    Problem Symptoms:
    Version 22 GUI Cataloging client gets message "ALEPH Catalog has stopped working" trying to display a search result, and needs to be restarted. [Screenprints attached to Case 00105226.
    [The same could occur with other clients: "ALEPH Circulation has stopped working", "ALEPH Acquisitions has stopped working", etc.]

     

    Cause:
    Version check not done on PC after application of Service Pack.

     

    Resolution:
    In GUI, click on Aleph in the upper left, select "Version check" from the dropdown, and run.

     

    Additional Information
    Steps in diagnosis ...

    1. confirm that the server/port being connected to is the v22 server/port; 

    2. if other staff are also accessing v22 via the GUI, check if they have the problem; 

    3. does the same thing happen with a search in the circ client? 

    4. connect to the server with ssh, enter the "ver" command, and record the result; 

    5. go to /exlibris/aleph/a22_1/aleph/pc_exe/sp_exe/catalog/bin/ on the server and note the size and date of the catalog.exe file 

    6. on the PC, click on the "Help" option in the bar at the top, select "About" from the dropdown, and record the result; 

    7. go to the .\Catalog\bin folder on the PC; note the size and date of the catalog.exe file. 

    Compare the size and date of the catalog.exe from step 5 to those from step 7. And the version, from step 4 to that in step 6.

     


    • Article last edited: 02-Mar-2016
    View article in the Exlibris Knowledge Center
    1. Back to top
      • GUI crashes when we click on Staff Privileges
      • GUI Custom Service in v19: "Unable to find correct permission…”.
    • Was this article helpful?

    Recommended articles

    1. Article type
      Topic
      Language
      English
      Product
      Aleph
    2. Tags
      This page has no tags.
    1. © Copyright 2025 Ex Libris Knowledge Center
    2. Powered by CXone Expert ®
    • Term of Use
    • Privacy Policy
    • Contact Us
    2025 Ex Libris. All rights reserved