Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Impossible to waive credited transaction

     

    • Product: Aleph
    • Product Version: 20, 21, 22, 23
    • Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care

     

    Problem Symptoms:
    When trying to Waive a cash transaction with "Credited" in its GUI Status column, the following message appears:
    "It is impossible to waive a credited transaction or a transaction which is non 'Not Paid'. If you press OK, the waiving process will continue but transactions that are not relevant will be ignored."

    If OK is pressed, the system replies:
    "There are no relevant transactions for waiving process."

    and the transaction is not removed.

    Cause:
    Working as designed.

    Resolution:
    "Waive" means to forgive the payment of an amount which is owed. The "waiving" of a credit does not make sense because the money is not owed to library by the patron, but, rather, *to* the patron by the library.
    It is assumed that removal of the Credit transaction is desired because it is erroneous or because the student has left school.
    Ideally, there would be a "Delete" button which could be used to delete it, but there is none.

    There are two possibilities:
    1. If there are just a few such cases, create a "Cash Note" indicating the reason that the transaction is being cancelled and do "Pay Selected"; or
    2. If there are more than a few cases or if choice #1 is not acceptable, use SQL to delete the transaction(s).

     

     

     


    • Article last edited: 02-Mar-2016