Skip to main content
ExLibris

Knowledge Assistant

BETA
 
  • Subscribe by RSS
  • Back
    Aleph

     

    Ex Libris Knowledge Center
    1. Search site
      Go back to previous article
      1. Sign in
        • Sign in
        • Forgot password
    1. Home
    2. Aleph
    3. Knowledge Articles
    4. localhost_access_log files not being written to jlog directory

    localhost_access_log files not being written to jlog directory

    1. Last updated
    2. Save as PDF
    3. Share
      1. Share
      2. Tweet
      3. Share
    No headers

     

    • Product: Aleph
    • Product Version: 20, 21
    • Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care

     

    Problem Symptoms:
    localhost_access_log files are not being written to the /exlibris/aleph/a2n_n/ng/aleph/home/system/thirdparty/openserver/server/default/log/ directory (the "jlog" directory) .

    The jlog directory has server.log.xxxx files but no localhost_access_log.yyyy-mm-dd files.

     

    Cause:
    JBoss was upgraded, and a default change was made to the /exlibris/aleph/a2n_n/ng/aleph/home/system/thirdparty/openserver/server/default/deploy/jbossweb.sar/server.xml file to turn this off.

     

    Resolution:
    1. Enter the command "jdeploy" to get to the deploy directory:
    > jdeploy
    > cd jbossweb.sar

    2. Save the existing server.xml file:
    > cp -p server.xml server.xml.beforechange

    3. Edit the server.xml file:
    > vi server.xml

    Uncomment the "org.apache.catalina.valves.AccessLogValve" line: 

    <!-- Access logger -->
    <!-- <--- delete this begin-comment line
    <Valve className="org.apache.catalina.valves.AccessLogValve"
    prefix="localhost_access_log." suffix=".log"
    pattern="common" directory="${jboss.server.log.dir}"
    resolveHosts="false" />
    --> <--- delete this end-comment line

    4. Restart jboss.

     

     


    • Article last edited: 02-Mar-2016
    View article in the Exlibris Knowledge Center
    1. Back to top
      • Local users not displaying in patron list when checkbox "Display local patrons only" is ticked
      • Locate error messages in "Update Word Index" (manage-01) log
    • Was this article helpful?

    Recommended articles

    1. Article type
      Topic
      Language
      English
      Product
      Aleph
    2. Tags
      This page has no tags.
    1. © Copyright 2025 Ex Libris Knowledge Center
    2. Powered by CXone Expert ®
    • Term of Use
    • Privacy Policy
    • Contact Us
    2025 Ex Libris. All rights reserved