Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    New UI not loading correctly after login using PDS

    • Product: Primo
    • Product Version: August 2016, November 2016
    • Relevant for Installation Type: Dedicated-Direct, Multi-Tenant, Total Care, Local

    Description

    • Sign In to Classic UI is successful, yet Sign In to New UI fails
    • The New UI displays correctly when not logged in (i.e as a guest)
    • Primo is configured with:
      • Alma as the ILS
      • PDS for authentication
    • PDS uses Alma for Patron Information
    • The Primo & Alma Institutions are not the same (e.g. MYU vs. MYU_INST)
    • PDS is not configured with a <PDS_INSTITUTE>_primo.tags file (e.g. MYU_INST_primo.tags or MYU_primo.tags)

    Resolution

    Multi-Tenant and Total Care Customers
    1. Open a case requesting PDS be updated; include a reference to this article
    Direct-Dedicated & Local Customers (who have server-level access via the "primo" user)
    1. Login to the PDS server (usually the FE server) as the primo user
    2. Enter the commands:
      1. pds_root
      2. cd conf_table
    3. Create a tags file for Primo called <PDS_INSTITUTE>_primo.tags, replacing <PDS_INSTITUTE> with your PDS Institution (e.g. MYU_primo.tags)
    4. Add the code below to the tags file, replacing <PRIMO_INST> and <ALMA_INST> with the Primo and Alma Institution codes respectively
    5. Repeat all the steps for all PDS/FE servers
    [ATTRIBUTES_VALUES_MAPPING]
    institute,<ALMA_INST> = institute,<PRIMO_INST>
    [END]
    

     

     


    • Article last edited: 10-Oct-2017
    //Feedback