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    Records showing "Available At" blank in Primo search results for Real Time Availability

    • Article Type: General
    • Product: Primo

    Problem Symptoms:
    * Record RTA shows as "Available At" blank in the search results
    * All <availlibrary> fields in the <display> section of the record's PNX have $$9ONLINE
    * No <delcategory> fields in the <delivery> section of the record's PNX have "Online Resource"

    Cause:
    Primo does not consider records for the alsophysical Virtual Delivery status denoted by $$9ONLINE in the availlibrary fields if no <delcategory> fields report the record to be an Online Resource.

    Resolution:
    This problem is an error in cataloging or Normalization rules.
    If the record is really an online resource then change the <delcategory> field to "Online Resource".
    If the record is really a physical item then remove the $$9ONLINE from the <availlibrary> fields.

    Additional Information

    The $$9ONLINE is placed in <availlibrary> fields that have holding information for an online only record. If a record has a <delcategory> of Online Resource, Primo checks all the <availlibrary> fields for $$9ONLINE, and if it finds one that does not have the value, it think that this line is for a physical copy and informs the user that the record is Online Access, but physical copies may be available. This is the alsophysical Virtual Delivery category.

    If no <delcategory> fields say "Online Resource" then Primo does not check for the alsophysical status because it does not think the record has online access. It still will not display RTA availability information for any <availlibrary> fields with $$9ONLINE which causes this problem.

    Category: Front End - Primo

    Subject: Avaliability/RTA - Primo


    • Article last edited: 9/10/2014