ACQ: "Receive items" for EDI not recorded in database
- Article Type: General
- Product: Voyager
- Product Version: 9
Problem Symptoms:
* Check "Receive items" box during EDI load
* Line item on invoice Received Complete
* No indication in the client or database that this box had been checked when the invoice was loaded.
Cause:
This behavior is the result of issue VYG-5754.
Resolution:
VYG-5754 is resolved for Voyager 9.1.0 and higher.
Additional Information
Replication steps:
In Acquisitions
1. Create & approve PO for line item. (For attached EDI file, "HIGH SCHOOL JOURNAL"). Do not receive line item.
2. In EDI > Process EDI Messages, click on "Receive File"
3. Choose a file (goodebsco.edi attached)
4. Click on "Receive Items" checkbox.
5. Click "Load"
6. Result:
6.a. Creates invoice.
6.b. Items received. BUT
* "Receive items" no longer checked.
* No indication in DB that it was checked at time of load -- for example:
select receive_items, create_date, update_date
from edi_message
where msg_number='54529'
R CREATE_DA UPDATE_DA
- --------- ---------
N 15-MAY-14 15-MAY-14
Workaround: None.
- Article last edited: 15-Aug-2022