ACQ: wrong fund displays and saving can result in data corruption
- Article Type: General
- Product: Voyager
- Product Version: 9.1
Problem Symptoms:
*Opening a fund before the entire ledger loads results in the wrong fund loading.
*Opening a fund before the entire ledger loads results in some reporting funds not loading.
*Editing a fund when the wrong fund opens and displays results in data corruption.
Cause:
This behavior is the result of Issue VYG-5809.
Resolution:
Issue VYG-5809 is resolved for Voyager 9.1.0 and higher.
Additional Information
Replication steps:
1. Create a ledger with a summary fund, approximately 20 Allocated funds, below it, and reporting funds below that.
2. Open Acquisitions with a slow internet connection or connecting to a remove Voyager server.
3. Search for the ledger created in step 1.
4. As the ledger loads, expand the Summary fund.
5. All of the Allocated funds will be listed and plus signs will slowly appear in the front of the fund names in order to expand the allocated funds.
6. Double click on one of the allocated funds for which the plus symbol has not yet showed up.
7. A different fund will open.
8. Close and reopen the ledger and time for all of the funds to load. The funds will display and load correctly.
9. Or, edit the fund opened in step 7 and save.
10. Close and reopen the ledger.
11. The fund from step 6 will have the same fund_id, but will have some elements changed (fund name, fund category) and the parent fund will be set to 0. This results in the fund being directly under the ledger, even if the Fund Category is now set to Reporting.
Workaround:
Do not open funds until a ledger has completely finished loading. If the incorrect fund loads, close and reopen the ledger.
Category: Acquisitions - Voyager
Subject: Voyager
- Article last edited: 10/16/2014