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    CIRC: Recall on term loan doesn't shorten due date

    • Article Type: General
    • Product: Voyager
    • Product Version: 8.2.1

    Problem Symptoms:
    * item is charged to a patron with a term loan, message indicates due date is shortened, but is not actually shortened.
    * additionally, manually changing due date is denied as long as recall remains on item.

    Cause:
    This behavior is the result of issue VYG-5458.

    Resolution:
    VYG-5458 is currently in Development.

    Additional Information

    Replication steps:
    1. In System Administration, set up two matrix entries for the same item type so that
    a. Patron Group 1 (PG1) has a term loan
    b. Patron Group 2 (PG2) has a day loan
    c. For both, Min. loan period for recall (MPR) = 7 days / Recall return interval (RRI) = 3 days / Recall grace period (RGP) = 1 day
    2. Make sure there are term loan dates in the calendar for the policy.
    3. In Circulation, charge an item of same type set up in matrix in step 1 to a patron.
    4. Add 3 recalls to the item:
    a. Recall the item for a patron in PG1.
    b. Recall the item for a patron in PG2.
    c. Recall the item for a third patron (PG irrelevant).
    5. Discharge the item. Note that the item is now on hold for the PG1 patron.
    6. Charge the item to the PG1 patron (term loan). Receive message:
    "The loan period has been shortened from the normal interval as another patron has requested the item."
    7. Click OK and note that the due date has not actually been shortened but is the term loan due date.
    8. Right-click on the item in the Charge window & select "Modify Due Date ..."
    9. Choose a new due date in keeping with the shortened recall interval and click OK. Receive message:
    "BLOCKED ? Item on line 1 has a pending recall. Unable to change the due date."
    10. If you attempt to change the due date from the Charged Items Index in the patron record, you receive a similar message (line number varies according to position in list you're modifying due date from).
    11. Discharge item & charge to PG2 patron (day loan). Same behavior & messages, except the due date is shortened as message indicates (to MPR + RRI + RGP).

    Workaround: Cancel recall, adjust due date & replace recall request

    Category: Circulation


    • Article last edited: 5/29/2014