DISCHARGE_DATE populated in FINE_FEE table, but no record of discharge in CIRC_TRANS_ARCHIVE
- Product: Voyager
- Relevant for Installation Type: Multi-Tenant Direct, Dedicated-Direct, Local, TotalCare
Problem Symptoms
- circjob.log shows
Mon Oct 29 01:40:01 2018 Update Accrued Fines/Demerits...
Mon Oct 29 01:40:21 2018 ...COMPLETED
- Items are getting a DISCHARGE_DATE on the FINE_FEE table, but no record of discharge on the CIRC_TRANS_ARCHIVE table
- Items still show as charged.
Cause
Items are currently overdue, still charged to patrons, and have been assessed accrued fines.
Solution
- Job runs and accrued fines and fees are calculated and updated in FINE_FEE table. DISCHARGE_DATE field is populated with the date/time of the assessment of the accrued fine (i.e., when the job runs).
- When items are returned and discharged at circulation desk, FINE_FEE will be updated with the final fine/fee assessment and DISCHARGE_DATE will reflect date of discharge
- Article last edited: 29-Oct-2018