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    Due date is set to the end of the current day when renewing overdue items.

    • Product: Voyager
    • Product Version: 8.2.1

    Problem Symptoms

    • Due date of a renewed item is set to the end of the current day by Circulation.
    • Item status prior to being renewed was overdue.
    • 'Renew From' option in the relevant Circulation Policy Definition Matrix record is set to "Original Due Date."

    Cause

    The date the item is being renewed is past the maximum possible due date of the item. When an item past its maximum possible due date is renewed, its due date is set to the end of the current day.

    Resolution

    This solution will remove any limit on the maximum possible due date when "Renew If Overdue" is checked in the "Policies" tab in Policy Definitions.

    1. Open SysAdmin > Circulation > Policy Definitions
    2. Edit the Policy definition in effect for the renewed item.
    3. In the Matrix tab, modify each item in the policy matrix and set the "Renew From" option to "Renewal Date"
    4. Save all changes and exit.

    Additional Information

    Maximum possible due date of the item is calculated as: Original Due Date + (Renewal Period * Maximum Number of Sequential Renewals).

    Example:

    • Original Due Date is January 1st
    • Renewal period is 7 days
    • Maximum number of renewals is 2

    Item is renewed on January 18th: January 1st + (7 days * 2) = January 15th = Maximum Possible Due Date

    Item will be due at the end of the day on January 18th. A maximum possible due date only applies when "Renew From" option in the Circulation Policy Definition Matrix is set to "Original Due Date."


    • Article last edited: 21-Apr-2014
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