Duplicate address fields for Patron Self-Registration records
- Article Type: General
- Product: Voyager
- Product Version: 7.2.3
Problem Symptoms:
? Patron records created via Patron Self-Registration have following fields being duplicated in the database (one set for address_line1 and one set for the e-mail address): patron_address.city, patron_address.state_province, patron_address.zip_postal, and patron_address.country.
? Patron records created via Circulation client do not have these fields duplicated.
Cause:
This behavior is caused by Issue 16384-21073.
Resolution:
Fixed in Voyager 8.2.2.
Additional Information
Replication Steps:
1. Create a patron record with an e-mail address via Circulation client.
2. Create a patron record via Patron Self-Registration.
3. Look at patron_address table in DB for each record.
4. Note that patron_address.city, patron_address.state_province, patron_address.zip_postal and patron_address.country show twice (once for address_line1, once for e-mail address) in the record created via PSR.
Workaround: None
Category: Patron Self-Registration
- Article last edited: 10/8/2013