GDC: Scan to Exclude does not add records to set
- Article Type: General
- Product: Voyager
- Product Version: 8.1.0
Problem Symptoms
- Run Scan Job with Scan Rule set to Exclude records
- No records added to record set
Cause
"Exclude" means that records that meet the criteria for a rule with a consequence of Exclude will be excluded (i.e. not included) in the resulting record set.
The use of this consequence would be to use it in the rule set that created the original record set, and exclude some records that otherwise would be included in the results. To filter a record set and create a new smaller record set, construct a rule set using a rule that defines the records to Include in the new record set.
Essentially, in order to Exclude a record, it must first be Included in a set from which it can subsequently be excluded.
Resolution
Working as designed. Use include + exclude rule.
1. First rule: include all records.
2. Second rule: apply the exclude consequence to filter exclusions from final set.
Additional Information
Example: Create a set of all records in the database, except if the word "apple" is in title.
Rule 1: IF record contains 001, then INCLUDE {step 1: collect all potential records that could be added to the set}
Rule 2: IF record 245 contains "apple", then EXCLUDE {step 2: now remove any record from the set retrieved in step 1 that have "apple" in 245}
Final set: All records retrieved by first rule, excluding records with "apple" in 245.
- Article last edited: 31-Jul-2018