My account page slow to load; "Unable to connect to CLIO server" in log.voyager
- Product: Voyager
- Relevant for Installation Type: Multi-Tenant Direct, Dedicated-Direct, Local
Problem Symptoms
- In WebVoyage > My Account > after login, My Account page is slow to load (1 minute or longer to display page)
- Following logged in log.voyager:
opacsvr[16331] - ERROR - Mon Oct 29 08:56:51 2018
- GetPatronClioRequestStatuses - opac__ppc.cxx[1945]
Unable to connect to CLIO server
Cause
CLIO Server configuration is active but there is no CLIO (ILL) server.
Solution
- SSH to server as voyager user
- cd /m1/voyager/xxxdb/ini
- Edit voyager.env and comment out the following stanza as shown:
###################################
## CLIO Server
#export CLIO_SERVER=123.45.6.789
#export CLIO_PORT=7777
###################################
- Save changes and restart Voyager.
Additional Information
If you are running CLIO (ILL) and the server does exist, make sure it is running and accepting connections.
- Article last edited: 30-Oct-2018