Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Patron blocks not displaying when no Patron Rules

    • Product: Voyager
    • Product Version: 7.2.5

    Problem Symptoms

    Blocks not displaying in My Account for patrons with borrowing blocks.

    Happens for patron blocks for patron groups using (all) patron rules in the circulation policy that contains the OPAC Circ Desk

    Cause

    This behavior is likely a defect in an earlier version of Voyager.

    This behavior is not replicable in Voyager 8.2.2 and higher.

    Additional Information

    Replication Steps
    1. Identify or create a patron that belongs to a patron group using the (all) patron rules in the Circulation Policy that contains the OPAC Circ Desk location.
    2. Patron should have a block - i.e., lost items exceeding maximum allowed in patron rules.
    3. Log into WebVoyage as the patron. Note that the block message does not display (though the block is in effect).
    4. In SysAdmin, update the Circulation Policy so that the patron group now has its own patron rules defined.
    5. Log into WebVoyage again as the same patron. Note that the block message now displays.
    Workaround

    Assign patron rules to individual patron groups.


    • Article last edited: 29-May-2014
    • Was this article helpful?