Skip to main content
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Persistent Links don't include bib ID

    • Article Type: General
    • Product: Voyager
    • Product Version: 8.2.0

    Problem Symptoms:
    * Permalink is always http://<IP>:<port>/vwebv/ holdingsInfo?bibId=
    * Records bib ID is not added to end.
    * The Bib ID for bibliographic records is not included in the persistent link URL, resulting in a persistent link with no record specified.

    This behavior is caused by Known Issue 16384-21009 / VYG-1893

    Addressed in Voyager 8.2.2 and higher. See revisions to WebVoyage Architecture and Configuration Models.

    Additional Information

    Replication steps:
    1. On the server, in the skin you wish to add a Persistent Link to bibliographic records to, follow the instructions for adding this customization that are outlined in the WebVoyage Architecture and Configuration Models document in the chapter titled ?How Do I Build And Display a Persistent Link To A Bibliographic Record??
    2. In your browser, conduct a search in the WebVoyage skin you just customized.
    3. From the titles list, click any bibliographic record.
    4. You should see a Persistent Link at the bottom of the record. Hover over it. Note that the URL that previews in the browser does not include the record?s bib ID and instead looks something like http://<IP>:<port>/vwebv/holdingsInfo?bibId= (where no bibId follows the equal sign)
    5. If you click this link, you receive ?WebVoyage System Error? as the link is invalid, pointing to no record.

    Workaround: Edit display.xsl:
    Comment out this line:
    <!-- <xsl:variable name="bibID" select="//hol:recordTypeRecord/@bibId"/> -->
    And replace it with this line:
    <xsl:variable name="bibID" select="//hol:bibRecord/@bibId"/>

    Category: Opac

    • Article last edited: 2/26/2014