Staff experiencing issues with searching and saving records
- Article Type: General
- Product: Voyager
- Product Version: 8.1.0
Problem Symptoms (where xxxdb is the Voyager Database Instance) :
* Staff experience issues when searching and saving records in the cataloging client
* Keysvr SMF services are in maintenance mode and cannot be cleared:
maintenance 15:32:09 svc:/site/ExLibris/Voyager/xxxdb/Pkeyshm:default
maintenance 15:32:16 svc:/site/ExLibris/Voyager/xxxdb/Pkeyqmgr:default
* The SMF log for these services shows this error:
-- ERROR -- Assertion failed: -1 != stat(logfilename, &logfilestat), file subsyslog.cpp, line 126
* Attempting to connect to the keysvr port (7060) or run Pkeysvr manually gives this error:
Assertion failed: mBlockSize != 0, file block.cpp, line 83
Cause:
The dynamic.dc file in the keyword index (/m1/voyager/xxxdb/data) has reached its 2 GB limit.
Resolution:
Run a regen. There are three options:
- If you are 300 Certified, run a regen according to the instructions
- If the server is running Voyager 8.1.0 or above, use the util menu
- Contact Support to schedule a regen
Category: Keyword Server
- Article last edited: 11/26/2013