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    4. UB / RESTful APIs: stub name deleted by renewal

    UB / RESTful APIs: stub name deleted by renewal

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    1. Additional Information
    • Article Type: General
    • Product: Voyager
    • Product Version: 8.1.0

    Problem Symptoms:
    * When UB renew request is sent, the name data in the stub record disappears.

    Cause:
    This behavior is the result of Issue VYG-4591.

    Resolution:
    VYG-4591 is resolved in Voyager 9.0.0 and higher.

    Additional Information

    Replication steps:
    1. Find a patron in Database 1 (DB1) who is UB eligible in Database 2 (DB2).
    2. Charge an item to the patron from DB1 in DB2 to create a UB charge transaction.
    3. In Primo or via RESTful API, submit a renewal request. You can submit the request from either interface (that is, log into DB1?s patron interface, or DB2?s patron interface).
    http://<DB1 or DB2 IP and Xservice port>/vxws/patron/<patron_id>/circulationActions/loans/1@<DB2?s db_key>%7C<item_id>?patron_homedb=1@<DB1?s db_key>
    4. The renewal is successful.
    However, if you now view the stub patron record in DB2, you will note that the name fields are blank, and PATRON.NAME_TYPE=0.
    5. When viewing stub patron record in Circulation, no patron name displays.
    The patron?s barcode and patron group are not touched, so the patron can still borrow material, but staff cannot verify patron name.

    Workaround:
    1. Open charge screen
    2. Select patron?s homedb from Library: drop-down
    3. Enter patron barcode.
    You will not need to charge anything ? the act of retrieving the barcode & patron information from the patron?s home database will update the data in the remote database.
    Charging an item to a patron in this manner (i.e., a walkup transaction) will correct this issue seamlessly.

    Category: (Voy Universal Borrowing)


    • Article last edited: 3/18/2014
    View article in the Exlibris Knowledge Center
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