Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Searching Resources

    Translatable
    New for November!   With Search Resources (Resources > Cataloging > Search Resources), you can search local resources such as the Institution Zone, Network Zone (where applicable), and the Community Zone plus any external database supported by Ex Libris Data Services.
    Alma supports copy cataloging by integrating the search and import of records located in external databases directly into the MD Editor. Resource searches may be done with any search target/database that is supported by Ex Libris Data Services and that has been enabled by your institution.
    If your institution is a member of a collaborative network, the list of available search resources is determined by the configurations and settings described in the External System Search in a Collaborative Network section.
    External databases can be searched from within the MD Editor interface, and records displaying in the results of the searches can be imported directly into Alma from the search results screen. In addition, when configured, Alma can search your repository for records that match the imported record, merge the variant records into a single record, or overlay the existing record with the imported record.
    To define the correct match profile to be used, you must include the appropriate file key in the serial_match_profile and non_serial_match_profile Parameter Value column (Configuration > Resources > General > Other Settings). For detailed information on these file keys, see the table in Configuring Other Settings.
    To configure external resources for searching including import, merge, and overlay, see Configuring External Search Resources. After you have defined/configured the external resources that you want to be able to search, you can create a search profile that identifies these resources for searching. For creating a search profile, see Configuring Search Profiles. Note that in the search profile, you can identify both external and local resources for searching.
    The resource search enables you to search external databases and view and select relevant records before importing them into the repository.
    In addition to the MD Editor, the search resources function is available from the Alma menu (Resources > Cataloging > Search Resources).
    When you have a record selected in the MD Editor and perform a search of local/external resources, the split editor option is automatically activated, and the relevant search fields are automatically populated with information from the current record in view.

    Working with Search Resources in the MD Editor

    This section describes working with Search Resources in the MD Editor.
    To search local/external resources:
    1. Open Search Resources (Resource Management > Resources > Cataloging > Search Resources).
      MD_Editor_Search_External_Resources_Page_NewUI_04_TC.png
      Search Resources Page
      You can also search resources by using the option in the MD Editor (Tools > Search Resources). When there is a record open in the MD Editor, the search fields are automatically populated with search terms from the open record, as shown in the following example.
      MD_Editor_Search_External_Resources_Page_with_Draft_Record_Open_NewUI_04_TC.png
      MD Editor Search Resources Page
      Note that the Search Resources option is not selectable when the record open in the MD Editor is linked to the Community Zone. If you select Copy to catalog (File > Copy to catalog), the link is broken; and you can select the Search Resources option (Tools > Search Resources) in the MD Editor.
    2. From the Search Cataloging Profile drop-down list, select one of the predefined search profiles. For details on defining a search profile, see Configuring Search Profiles.
    3. Enter the search values in any of the available fields according to the field name and select the required input expectation for the fields that you enter. You can select the input expectations from:
      • Contains Phrase
      • Contains Keywords
      • The Year of Publication field must contain four digits.
      • The condition Tag Suppressed (Title) with a value equal to No, is automatically added as part of your search criteria.
    4. Select whether you want each of the search fields to have And/Or options between them.
    5. Select Search. See search result examples below. Select Refine Search if you want to modify your search criteria.
      Search_Resources_Results_06.png
      Search Resources Results Page - Example 1   New for November!
      External_Search_Results_Page-Example_2_04.png
      Search Resources Results Page - Example 2
      The results from the search resources are shown in one or more tabs determined by your Search Configuration (see Configuring Search Profiles). The Search Configuration also determines the order in which the tabs appear. Note that you can have search results for local resources (New for November!) and external resources appear. In Example 1 above, the WorldCat configuration profile also specifies that the local Institution Zone and Community Zone should be part of the search that is processed.
      The Held by indication is displayed for OCLC (WorldCat) records only.
    6. To view the record details of an item on the Search Resources Results page, select the title of the item or select View; and select Back to Results to return to the  Search Resources Results page. (New for November!) Note that for local resources, you can select the Edit action.
    7. To import the record of an item on the Search Resources Results page from an external source, select the Import link for the title; or if you are viewing the record details (step 6), select Import. The record is imported into the Drafts folder of the MD Editor (and has a Drafts icon next to it), where you can manipulate it like any other record. This includes being able to create a PO line (see To create a PO line).
      When you import the record (or perform an overlay or merge), the originating system version of the record is updated to be the version of the record in the external catalog.To configure external search for import, overlay, or merge, see Configuring External Search Resources.

    Working with Search Resources in the MD Editor and Using KERIS

    Using Search Resources, you can access the following KERIS options (when they are configured for your system; see Configuring External Search Resources):
    • KERIS (Korea Education and Research Information Service)
    • KERIS (KORMARC)
    Search_External_Resources_in_the_MD_Editor_04_TC.png
    Search Resources in the MD Editor
    These resources predominantly contain more records in either the KORMARC record format or the MARC 21 record format. However, it is possible that both KORMARC-formatted and MARC 21-formatted records may appear in the results when using either of these external search resources. When importing records using search resources, the following methods are used to determine which record format to use when importing the record:
    • Default Implementation
      With this method when you import records from KERIS using Search Resources and the KERIS resource contains records in both the KORMARC record format and the MARC 21 record format, the KERIS KORMARC records are stored in the KORMARC Bibliographic folder as shown below when you use a profile configured for KERIS KORMARC.
      Record Imported in KORMARC Format When Using KERIS KORMARC
      When you import KERIS records using the KERIS (Korea Education and Research Information Service) profile, the records are stored in the MARC 21 Bibliographic folder, since using the KERIS (Korea Education and Research Information Service) profile indicates to Alma that you are importing a record in the MARC 21 record format.
    • Customized Customer Parameter (set by Ex Libris)
      With this method, Alma determines the record format by the contents in position 10 of the LDR. MARC 21 is identified by u or 2, and KORMARC is identified by c or k. The results for your resource searches appear with MARC 21 and KORMARC specified as determined by these characteristics. This indicates the record format that will be used when importing the record.
      MARC_21_KERIS_Record_Format_in_External_Search_Results_08.png
      MARC 21 and KORMARC Record Formats Identified in Search Resources Results

    Importing Records with Search Resources in the MD Editor and Viewing the UNIMARC Cross Walk

    See the following procedure for the steps to view the UNIMARC cross walk when importing records with Search Resources.
    To configure external search for import, overly or merge, see Configuring External Search Resources.
    To view the UNIMARC cross walk when you search resources/copy cataloging:
    1. Open the MD Editor (Resources > Cataloging > Open Metadata Editor).
    2. Create a new UNIMARC record (File > New > UNIMARC Bibliographic).
    3. Open the resources search tool (Tools > Search Resources).
    4. Complete a resources search in a MARC 21 database (such as OCLC).
    5. When the search results appear, select the Merge Preview link for the bibliographic record that you prefer.
      Merge_Preview_Link_02_TC.png
      Merge Preview Link
    6. View the appropriate fields in the preview content to confirm that the preview record has been converted to UNIMARC format. For example, the 700 field should display the author information.
      UNIMARC_700_Field_Author_Information_04.png
      UNIMARC 700 Field Example
    7. Select the Copy and Merge link and finish cataloging your record as usual.