ERROR Index Failure message encountered during BulkImport
- Product: Voyager
- Product Version: All
- Relevant for Installation Type: Dedicated-Direct; Direct; Local;
Problem Symptoms
- When BulkImport is running, the following message appears in log.imp.* file:
ERROR Index Failure while trying to create bib. Rejecting Record to error file
- Saving records in the Cataloging client may also give "Unable to add record" message.
Cause
- Database needs additional tablespace; or
- The dynamic keyword file is too large and a keyword regen is needed; or
- Problem with the import file data1.
Resolution
- Launch UTIL menu:
- SSH as voyager to server
- dlib xxxdb
- util
- Check tablespace:
- O: Oracle Maintenance
- C: Check the Oracle tablespace for xxxdb
- Enter oracle administrative user.
- Enter password.
- Note message:
Tablespace xxxdb used space is OK. It is using 45%. The maximum recommended used space is 80%.
ORTablespace xxxdb is using 80%. It EXCEEDS the recommended amount of % used.
- Message 2.5.2. will automatically give option to create an additional datafile.
- Check keyword information
- I. Index Maintenance
- I. Keyword Info
- Note "Keyword Regen suggested" value
- If "Yes", run keyword regen. See Note
- If "No", keyword index maintenance may not be needed.
- 1Try importing a totally different file of MARC records. Note especially any RDA 33x fields where the length of the subfield b is less than expected by the MARC standards (Media is 1, Carrier is 2, Content is 3).
- If steps above do not resolve, or more information/assistance is desired, open a Case with Support via Support Portal, and include any steps taken to attempt resolution and the outcome of those steps.
Note
IMPORTANT: During a keyword regen, your catalog is read-only. It can be searched, and Circulation activities can continue, but no catalog records can be updated.