Get "Connection Refused" when trying to open up Voyager client
- Product: Voyager
- Relevant for Installation Type: Multi-Tenant Direct, Dedicated-Direct, Local, TotalCare
Description
Get "Connection Refused" error when trying to open up ("run") Voyager client such as Cataloging. You may see other errors as well including "A database error occurred while attempting to load security locations" (or something similar).
Cause
This error is often related to connectivity issues and may occur if the port for the client is not open due to firewall or other security related reasons.
Resolution
Determine which port is being used (see: Network Ports used by Voyager and What goes in voyager.ini file?)
Check that the port is open in the firewall:
- If server is hosted by Ex Libris see Add an IP address to access Ex Libris Products Through Hosted Server
- If server is locally hosted, contact your I.T. Department.
Additional Information
Here are some troubleshooting steps you can try:
- Check to make sure your PC is on the internet by going to http://www.google.com or some other site.
- Double-check that on your PC that the voyager.ini file in C:/voyager is correct.
- Go to a different staff PC running the Voyager clients and try logging into the clients there.
- If you have SSH access to your server, connect and login via the voyager user. Run the following command (note that the port is dependent upon your site's port series; in this example it is checking port series 70xx):
[VGER] voyager@aio0037 : voyager/ $ telnet localhost 7010
You should see something like this (which will show you that the Circulation function is alive on the server):
Trying 127.0.0.1... Connected to localhost. Escape character is '^]'
- Article last edited: 30-Jul-2019