Run MARC Record Bulk Export in WebAdmin and nothing happens
- Product: Voyager
- Relevant for Installation Type: Multi-Tenant Direct, Dedicated-Direct, Local, TotalCare
Problem Symptoms
- Run MARC Bulk Export ("BulkExport") through WebAdmin
- No e-mails received indicating job progress
- No Bulk Export log files created
- Subsequent jobs do not run
Cause
This may occur if a wa-task.file gets stuck and prevents any other wa-task files from completing (See Basic steps in the Voyager WebAdmin operation flow to learn about wa-task files).
Resolution
SSH to the server and login as the "voyager" user.
Remove wa-task files from /m1/voyager/tmp and restart WebAdmin.
- On the server, navigate to /m1/voyager/tmp
- Remove all wa-task files from tmp directory
[VGER] voyager@xxxx : tmp/ $ rm wa-task* - cd ../xxxdb/sbin (where xxxdb is the Voyager Database Instance)
- Pwebadmind restart (or wait until after the next server reboot)
OR
If /m1/voyager/tmp has accumulated a large number of files, you can move the /tmp directory off and start fresh.
- cd /m1/voyager
- mv tmp tmp.<date>
- mkdir tmp
- chmod 777 tmp
- cd xxxdb/sbin (where xxxdb represents your Voyager database instance name)
- Pwebadmind restart (or wait until after the next server reboot)
Additional Information
The WebAdmin back end only runs a single task at a time. If the current job gets interrupted for any reason, the job's wa-task* file is not deleted, and when WebAdmin scans for the next task to run, it will find that task. This can result in a "loop" and prevent succeeding WebAdmin jobs from running. The solution is to identify the job, remove its wa-task* file from the queue directory. and then kill the job.
See also: Run BulkImport in WebAdmin and nothing happens
- Article last edited: 10-Sept-2020