User cannot retrieve Ledger in Acquisitions
- Article Type: General
- Product: Voyager
- Product Version: 6.5.3
Problem Symptoms
Ledger has "disappeared" from various access points in Acquisitions client
Cause
Problem occurs when locations associated with the ledger(s) are not included in the Acquisitions Security Profile for the operator. If even one of the locations in the ledger is not in the Security Profile, the operator will not have access to the ledger(s) or any of its associated funds.
Resolution
To figure out which location is selected in Ledger, but not in user's Acquisitions Security Profile:
- System Administration > Security > Operator Profiles > New
- Create new operator (e.g. "Test" with operator id/password "test")
- Save
- System Administration > Security > Acquisitions/Serials Profiles > New
- Create new profile (e.g., "Test")
- Operator > move operator created in step 2 from Available to Selected column
- Locations > move all locations to Selected column
- Save.
- Acquisitions > log in with new test operator from step 2
- Acquisitions > Ledgers and Funds > Search Ledgers > [search for ledger in question]
- Open ledger > Locations > compare locations in ledger to locations in the Acquisitions/Serials Security Profile that cannot retrieve ledger
- Find location(s) selected in ledger, but not selected in operator's Acq/Serials Profile
- Move that location from Available to Selected in operator's Acq/Serials Profile
Ledger should now be retrievable once operator starts new session in Acquisitions.
- Article last edited: 07-Jan-2020