Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Managing References

    Adding References

    Finding References to Add to RefWorks

    To search for references to add to RefWorks:

    Try any of the following workflows:

    • If you have references in files (PDFs, Word Documents, videos, and so forth), you can upload them to RefWorks (see Uploading Files as References).
    • Add references to RefWorks directly from websites using direct export (when supported) or using the Save to RefWorks bookmarklet. See Save to RefWorks.
    • From within RefWorks, you can search an external database for references. See below.
    • You can add references from folders that are shared with you by other users. See Working with Shared Folders of References, below.
    • When configured by your institution, you can search for references in your local library catalog. When you find an item in your library's catalog that you want to add to RefWorks, select Send to > RefWorks on the item page, or download the reference and upload it to RefWorks. To open your library's catalog from within RefWorks, select Add > Create New Reference and in the right sidebar select Find full-text using link resolver (your institution may have renamed this link).
    To search an external database from within RefWorks:
    1. Select Search Databases in the left sidebar. RefWorks replaces the Main Navigation area with a search bar.

      right_sidebar_highlighted.png

      Search Databases
    2. Select the database. This field uses auto-complete.
    3. Use the basic search to search all fields, or select Advanced to search in specific fields.
    4. Select anywhere in a result to view details about the reference in the right sidebar. To add results as references, select one or more results and select Import. If you have multiple projects, select a project to which you want the references imported. The references are added to the Last Imported tab. To instead add the selected references directly to a specific folder, select the folder icon and the folder name.

    Manually Adding References

    To manually add a reference:
    1. Select Add > Create New Reference. The right sidebar appears.

      right_sidebar_highlighted.png

      Right Sidebar
      To add a reference directly to a folder, select the folder in the left sidebar and then select Add > Create New Reference.
    2. Select the reference type. The remaining fields on the sidebar change depending on the type you select. The fields Attachment, Tags, and Title are always available.
    3. Enter a title or as much of the title as you can. You can optionally select the locate button title_locate.png in the Title field to have RefWorks match the title with an item in the library. This button is also available after you enter a value in the DOI field, which appears for most reference types (select Add more fields to see this field, if it is available). RefWorks displays possible matches at the bottom of the pane. If you select one, RefWorks completes the title and fills the fields with information from the library.
    4. If your reference is a file on your computer, or you have any other associated information in a file, drag and drop the file to the right sidebar or select Add an attachment to upload the file. Supported file types include Microsoft Word, Open Office, and PDF.
    5. Enter any required tags for this reference. If any tags currently exist for other references, you can select them. Tags are used for filtering references on the Tags tab in the left sidebar; see Organizing References by Tags.
    6. Fill in as many of the remaining fields that you can.
      • For more information, see Editing References.
      • If you have defined any custom fields (see Configuring Basic Information), you can select Add more fields to add them to the reference and then enter values for them.
      • You can also create and add custom fields while creating or editing the reference. Enter the custom field name in Add more fields and select Add "..." as a custom field.

        add_new_field.png

        Add Custom Field

        The custom field is saved and added to the reference. The custom field is now available to be added to all references.

        new_field_in_reference.png

        New Custom Field
    7. When you are done, select Save.

    Uploading Files as References

    To upload files to RefWorks:

    Either drag and drop a file onto the center pane or select Add > Upload Document and select the file. The file can be in any format.

    The file is uploaded as a reference with type Generic. RefWorks attempts to automatically extract as much information as it can from the uploaded file. Edit the reference to correct and complete the information.

    If you drag and drop multiple files at one time, a reference is created for each file.

    Importing References

    You can import existing references from any reference management service. You can import directly from another RefWorks account or from your Mendeley account. For other services, such as Zotero, you can import a file that you have exported from that service. Also see Exporting References to a File.

    To import references from a reference management service:
    1. To import from a reference management service other than RefWorks or Mendeley, export them from that service to one of the following formats: NLM PubMed, RefWorks Tagged, RefWorks XML, RIS, or Thomson Reuters format. For example:
      • Zotero: Select the references and select Export Selected Items from the right-click menu. Select RIS and save the file.
      • EndNote: 1) Select Edit > Output Styles > Open Style Manager and select RefMan (RIS) Export. 2) In your library, select the references, select File > Export, and save the file as RefMan (RIS) Export.
      • ReadCube: From the library view, select the article or articles, select Export to RefMan (RIS) file from the right-click menu, and save the file.
      • Papers: In your library, highlight the references, select File > Export ..., select Refman RIS, and save the file.
    2. Select Add > Import references. The Import from another reference manager page appears.

      import_from_another_reference_manager.png

      Import From Another Reference Manager
    3. To import from RefWorks or Mendeley, select the relevant action and select Authorize. The login page of the relevant citation manager appears. Log into the citation manager.

      Otherwise, drag and drop the file containing the list of exported references or select select a file from your computer, select the file, select the relevant format (and, for RIS or Thomson Reuters formats, select the closest matching database), and select Import. Your references are copied from the other service to RefWorks.

      In both cases, your references are added to RefWorks.

    Organizing References

    Viewing Your References

    You can view a list of your references, a subset of your references, folders of shared references, or deleted references by searching or by selecting the relevant tab in the left sidebar (see The RefWorks' User Interface). Each reference includes a unique reference ID (Ref ID).

    Your options for viewing references include the following:

    Reference View Options
    What to View How to View Description and Notes Select Sort Method?
    All All References   Yes
    Matching a search string Search Use the basic search to search all fields, or select Advanced to search in specific fields. In the basic search, enter a tag name or any search string. After entering your search criteria, your search appears as an encoded query string in the basic search box and the matching references appear in the center pane.

    If advanced queries are enabled, the search text appears in blue.

    enable_advanced_queries.png

    Enable Advanced Queries

    You can enter an encoded query string directly in the basic search field. For example, to search for a reference that is not in a folder and that contains the author "Rowling" and the tag "mandatory", the search string is _missing_:collectionIds (authors:(rowling) reference.tags:(mandatory)). For a list of how to format an advanced query, see RefWorks Reference Fields and Types.

     
    Recently added Last Imported References added in the last 30 days. Select Delete to remove references. They will still be available in My Folders (if they were previously placed there).  
    Shared with you by others Sharing > [folder name] References shared with you. See Working with Shared Folders of References. Yes
    By folder My Folder > [folder name] References in a specific folder or subfolder. Subfolders can be up to three levels deep, for example main > sub1 > sub2 > sub3. Yes
    Not in any folder My Folder > Not in Folder References that are not assigned to a specific folder or subfolder. Yes
    By tag Tags > [tag name] Search for tags in this area. After selecting a tag, the encoded query string that matches references associated to that tag appears in the basic search box. For example, tags:"mandatory".  
    Containing a value in a custom field Settings > [field name] Display references using this field References that have values in a custom field that you added to RefWorks. On the Settings page (select Settings in the main menu), hover your mouse over the field and select the link that appears.  
    Deleted Deleted References deleted from other tabs and folders. You can restore them references using the Undo action. To permanently remove some references, select the relevant references and select Delete > Delete selected and select Yes in the confirmation dialog box. To remove all references, select Delete > Empty Trash. Yes

    The number of references appearing on the page appears at the top of the page. Actions at the top enable you to move between reference pages, change the number of references per page, and switch between view options:

    • Normal view – A minimalist view. Each reference's associated folders and tags are displayed, as well as an icon if access to the full text is available. Select the reference (not the checkbox) to open the right sidebar for reference details.

      normal_view.png

      Normal View
    • Full view – An expanded view. Select a tag to refresh the page with all references associated with the tag. Select the text link to view the full text, if available. Select any other field to open the right sidebar and edit that field.

      full_view.png

      Full View
    • Citation view – A bibliographic view. The references appear as they would in your default citation style. Select the gear icon settings_icon.png in the view options menu to select a different style.

      RefWorks highlights missing fields that are required or recommended for the selected citation style. Select a highlight to open the right sidebar and edit that field.

      citation_view.png

      Citation View
    • Table view – Another minimalist view. References appear in a table for easy sorting. Note that this view is limited to 2,000 citations; to view more than 2,000 references in a table, export the references and open them in a spreadsheet program, such as Microsoft Excel.

      table_view.png

      Table View
    If you display a large number of references on one page, especially if you use full view, RefWorks may take a while to display the reference list.

    Accessing Full Text from RefWorks

    When viewing a reference with electronic access to partial or full text, you can access it from the right sidebar. This may be access to the text within the library or on an external site, or the uploaded file.

    right_sidebar_with_read_link_highlighted.png

    Right Sidebar

    When viewing a list of references in full view, select the text link (if available) to view the text.

    full_view_with_text_link_highlighted.png

    Full View: Links to URL and Uploaded File

    For some references, such as uploaded files, full view of the reference is provided directly in RefWorks. The RefWorks reader enables you to download the document, highlight text passages, and add comments and notes.

     

    Organizing References by Folders

    To manage the folders for one or more references:

    Select the references and select Assign to Folder. You can assign the selected references to an existing or new folder or remove them from a folder.

    Folders appear in the My Folders tab in the left sidebar. The number of references in a folder appears after each folder name.

    When the My Folders tab is expanded, you can drag and drop references to a folder. In addition, you can use this area to add a folder or a subfolder, or rename, delete, or share a folder. Subfolders can be up to three levels deep, for example main > sub1 > sub2 > sub3. Some of these actions are available in the folder's action menu.

    folder_actions.png

    Additional Folder Actions

    Organizing References by Tags

    To manage the tags for one or more references:

    Select the references and select Add Tags. You can associate the selected references with an existing or new tag or remove their association with a tag.

    When the Tags tab in the left sidebar is expanded, you can drag and drop references onto a tag to associate them with that tag.

    You can also manage tags when editing a reference in the right sidebar.

    Editing References

    • To edit a single reference - normal view: Select the reference in the center pane. This opens the reference details in the right sidebar. Select the edit icon edit_icon.png , edit the reference, and select Save. If you have defined any custom fields (see Configuring Basic Information), you can add or edit them as well. For more information, see Manually Adding References.

      When configured by your institution, you can add full text to a reference by searching for the reference in your local library catalog. When you find an item you want to add to RefWorks, select Send to > RefWorks on the item page, or download the text and upload it to the reference. To open your library's catalog from within RefWorks, when editing the reference select Full Text Search (your institution may have renamed this link).

    • To edit a single reference - full or citation view: Select any field in the reference to open the right sidebar directly in edit mode (you do not have to select the edit icon).

    A rich-text edit bar is available when you select contents within certain text fields (including Title, Alternate Title, Abstract, Notes, and any custom fields that you added to RefWorks).

    rich_text_edit_bar.png

    Rich Text Edit Bar
    • To edit references in bulk:
    1. Select one or more references and then select Tools > Bulk Edit. The Bulk Edit page appears.

      global_edit.png

      Bulk Edit
    2. Optionally select to edit all references and not only the references you selected in step 1.
    3. Select whether to add a field, delete a field, or replace part of a value in a field.
      • Add: either add a field or add to the electronic source fields.
        • Add a field: select Add, select the field name, enter the value, and select what to do if the field already contains a value: leave the value alone, overwrite the value, or append the new value to the existing value. You cannot append a date field. Select Add Data and select Yes in the confirmation dialog box.
        • Add to the electronic source fields: select Add, select Add to electronic source fields, enter values for Source Name, Source DB, URL, and/or Date Retrieved. Select what to do if the field already contains a value: leave the value alone, overwrite the value, or append the new value to the existing value. Select Add Data and select Yes in the confirmation dialog box.
      • Delete: select Delete, select the field, select Delete Data, and select Yes in the confirmation dialog box.
      • Replace: select Replace, select the field, enter the string to replace - you can select whether to match case and/or match a whole word only - and the new string, select Replace Data, and select Yes in the confirmation dialog box. Note that you cannot use regular expressions of any kind in either string: only simple text strings. Every instance of the matching string in the selected field is replaced with the new string.

    Removing Duplicate References

    If you have a large number of references, you have added references in bulk from several sources, or you are simply forgetful, it can be helpful to have RefWorks find and eliminate any duplicates from your collection.

    • Removing duplicates is available for shared projects, but not shared folders.
    • RefWorks can compare and find duplicates for up to 2,000 references.
    To remove duplicate references:
    1. Select Tools > Find Duplicates.

      OR in the My Folders tab select Find Duplicates in the folder action list.

      The Find duplicate references dialog box appears.

      find_duplicate_references.png

      Find Duplicate References
    2. If you selected the action while viewing a folder, or search results (including a tag), you can select whether to search for duplicates across all of your references or only the ones in the current list.
    3. Select the criteria for matching according to the details beneath each of the options.
    4. Select Find Duplicates. If any duplicates are found, they are highlighted and pre-selected to make them easy to delete.

      find_duplicate_references.png

      Duplicate References

    Restoring Deleted References

    If you deleted a reference from any folder or tab other than the Deleted tab, you can restore it. To restore a reference go to the Deleted tab, select the references to restore, and select Undo.

    Restore Selected References button

    Restore Selected References Button

    Copying References From RefWorks to Your Document

    When it comes time to cite your references in a document, such as Microsoft Word or Google Docs, you can use RefWorks to format one or more of your references for easy insertion into the document. You can insert a single reference or multiple references, and you can insert them inline and/or as a bibliography. You can select an out-of-the-box citation style (RefWorks or CSL style) or create your own style.

    To manage styles, see Managing Citation Styles.

    It is easy to create references in RefWorks to copy to your document, but it is even easier to add references while working in your document using a RefWorks plugin: In addition, you can manage references in a document using one of these plugins (delete, re-add, re-style, and so forth).

     

    To create a bibliography from one or more references:
    1. While viewing a list of references, select the desired references (or select none to use all references) and select Create Bibliography > Create bibliography. The Bibliography from ... page appears.

      bibliography_from.png

      Bibliography From ... Page
    2. Optionally select a different citation style. By default, the bibliography appears in the last style you used in RefWorks.
    3. Select Copy to Clipboard and paste into your document.
    To insert one or more inline citations (with or without a bibliography).
    1. While viewing a list of references, select Create Bibliography > Quick Cite. A dialog box appears.

      quick_cite_citation_style.png

      Quick Cite, Citation Style Tab
    2. Select a citation style and select Continue....

      quick_cite_insert_citations.png

      Quick Cite, Insert Citations Tab
      If you require numbered references, it is highly recommended to create citations and a bibliography within Word or Google Docs. Using Quick Cite, you must enter numbers or correct them manually in your document.
    3. To insert one reference, hover your mouse over the reference and select Copy citation. To insert multiple references as a unit, select the references and select the copy to clipboard icon. Paste into your document.
    4. To insert a bibliography, select the relevant references, either using the checkbox or the star icon, and select Continue to bibliography.

      quick_cite_insert_citations.png

      Quick Cite, Bibliography Tab
    5. Select Copy to Clipboard and paste into your document.

    Sharing References and Working with Shared References

    You can share folders of references with specific users and/or (when enabled) all other users at your institution and can view folders of references that are shared with you or your institution. You can view the references that have been shared with you, and in some cases add comments or change the references. If you want to edit or export references that have been shared with you, you must first copy them to your own reference folders.

    Sharing Folders of References

    To share folders:
    1. Select Share > Share folder

      OR in the Sharing area of the left sidebar, select Share a folder;

      OR in the My Folders area select Share folder in the row action list.

      The Sharing Settings dialog box appears.

      remove_url.png
      Sharing Settings
    2. In the Settings for area, select the folder to share.
    3. In the Settings for area, select whether to share the folder only with the email addresses you enter in the Shared with area, or with all users at your institution. You can change this as a later time.
    4. In the Public URL area, select Create Public URL to create a URL that you can use to share the contents of folders and sub-folders with others who do not have a RefWorks account.
    5. Select Remove URL to delete the URL and remove public access to the folder.
    6. In the Shared with area, enter the email addresses with which you want to share the folder. For each address, select whether the user:
      • Can read – Read refrences only.
      • Can annotate – Read and add comments and highlights to references.
      • Can modify – Add and remove references, add notes to references, and read and annotate attached supported PDF files.

      You can optionally enter a message to the user. The user receives an email notifying them about the invitation.

      You can view users with whom you have already shared the folder, and can change or remove their access.

    7. When you are done, select Done.

    To unshare the folder at any time, select Unshare Folder on the Sharing Settings dialog box and select Yes in the confirmation dialog box.

    Working with Shared Folders of References

    When a folder is shared with you, you receive an email indicating this. You can view the folder in the Sharing tab in RefWorks. All folders shared with you from a single institution are grouped together.

    folders_shared_by_institution.png

    All Folders Shared by Ex Libris University

    To view the references in a shared folder, you must accept the invitation: select Join in the folder's row.

    shared_folder.png

    Folder Shared by Ex Libris University

    The folder appears in your left sidebar in the Sharing area. All tags for references in this folder are added to your list of current tags.

    • You can view the references and citations of shared folders. When enabled by the person who shared the folder, you can also add comments and notes to the citations or even remove or add citations to the references.
    • To export these references or to synchronize shared citations with Dropbox (when enabled by your institution, see Configuring Site Settings), you must copy the references to your own list of references: drag and drop the references to a folder or select Assign to Folder. You can also select Share > Copy Shared References to copy the references to All Documents.
    • You can remove your own access to a shared folder using the action menu in the folder's row. If you remove your own access to a shared folder, any tags that are associated only with references in that folder are removed from your list of tags.

    Exporting References to a File

    You can export your references so that another user can import them without logging in to your account, or in order to import them to another citation manager. Also see Importing References.

    To export references:
    1. Navigate to the folder you want to export, or from All References, or from any search results, select Share > Export references. The Export references dialog box appears.

      export_references.png

      Export References
    2. Select whether to export all references in the current folder / search results or only selected references.
    3. Select the output format: BibTeX, RIS, tab-delimited, or XML.
    4. Select Export. The references are exported, including their field names. In a tab-delimited file, the first row contains the field names.

    Working with Projects

    Managing Projects

    You can create projects in RefWorks. Projects allow you to maintain separate reference collections for different research projects.
    To manage projects:
    1. Select the arrow next to your project in the header and select Manage Projects.
      manage_projects.png
      Manage projects
      The My projects page appears:
      projects_list.png
      My Projects
    2. To create a new project, select Create a New Project. The following appears:
      create_a_new_project.png
      Create a New Project
    3. Enter a name for the project and select Save.
      The project is added to the list of projects. You can navigate between projects from the Project Menu at the top of the page.
    4. To rename or delete a project select Actions > Rename or Actions > Delete.
    To move references from one project to another:
    • Using the Export References feature:
      1. Select Share > Export references to export references from the project.
      2. Navigate to the project into which the references should be imported.
      3. Select Add > Import to import the references.
    • Using a Shared Folder (This method may be faster for a large number of references):
      1. In the project from which you want to move references, create a new folder (My Folders > Add Folder).
      2. Select the references you want to move, and move them to the new folder.
      3. Under My folders, select the folder, and under the More Options menu, select Sharing settings. The Sharing Settings window opens.
      4. Select Anyone within your organization may join this folder, and select Done.
      5. From the Project Menu, select the project to which you want to move the references.
      6. Join the shared folder (Sharing > Folders at your university > Join).
      7. Move the references from the shared folder to folders in the project.
      8. Leave the the shared folder (Sharing > [Name of shared folder] > Leave Shared Folder).
      9. From the Project Menu, select the original project.
      10. Stop sharing the folder (Sharing > [Name of shared folder] > Only invited people may access), and select Done.
    To set a project as the current project:
    Perform one of the following to set a project as the current project:
    • From the Manage Projects page, select Actions > Set as Current Project for the project.
    • Select the project name. The project is set as the current project and its page is opened.
    The following additional functions are available to be used with Projects:
    • The Write-n-Cite and Google Docs plugins use references from your current project. To change the project, navigate to the relevant project within RefWorks. 
    • When searching in a database and using the Export to RefWorks feature and in RefWorks Citation Manager you can select the project that you want to use.
      direct_export.png
      Import to RefWorks
    Documents can use references from only one project.

    Sharing Projects

    You can share your projects with other users of RefWorks. This gives them full permissions within the project, including adding, deleting, and modifying folders and references. Any shared owner of the project can delete the project, as long as it is not the current project of any shared owner.
    Sharing a project allows you to work collaboratively with other project owners when using RefWorks Citation Manager (RCM). A document with citations from the shared project can be emailed between users to which each owner can contribute. Each collaborator works on the document separately and then emails it to the other owners for further work, rather than multiple users simultaneously editing the document.
    Reference IDs within a project are unique. Therefore, when you add a reference to a shared project, it may receive a RefID that is not consecutive to the last RefID of a reference you created.
    You share a project by selecting Share this Project:
    • From the Project Menu:
      share_project_project_menu.png
      Share Project from Project Menu
    • From a project’s Actions button on the My Projects page (Project Menu > Manage Projects):
      share_project_action_button.png
      Share Project from Action Button
    The Project Sharing Settings page appears, displaying the people with whom the project is shared.
    sharing_settings.png
    Project Sharing Settings
    The following actions are available from this page:
    • To share the project with a member, enter an email address in the Invite Members to Join field and click Done.
    • To unshare the project with a member, click Remove next to the member’s email address and click Done.
    • To unshare the project with all members, click Unshare Project.