Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    RefWorks Plugins: Connecting Your Browser, Microsoft Word, and Google Docs to RefWorks

    Overview

    It is easy to create references in RefWorks to copy to your document, but it is even easier to add references while working in your document using a RefWorks plugin: In addition, you can manage references in a document using one of these plugins (delete, re-add, re-style, and so forth).

    In addition to plugins for your editing environment, Save to RefWorks is a browser bookmarklet that enables you to add as references to your RefWorks account directly from your browser.

    See the sections on this page for information about the plugin relevant for your environment.

    Plugin Environments
    Environment Plugin Notes
    Microsoft Word 2010 or 2013 (local installation only) Write-N-Cite 4.5.1725 for Windows Write-N-Cite for Windows works best with Word 2013 and 2016 (32 bit versions).
    Microsoft Word for Windows 2016 Write-N-Cite 4.5.1725 for Windows or RefWorks Citation Manager Windows users of Microsoft Office 2016 users can choose whether to use Write N Cite or RefWorks Citation Manager.
    Microsoft Word for Mac 2008 or 2011 Write-N-Cite 4.5.1765 for Macintosh  
    Microsoft Word for Mac 2016 or Microsoft Word for iPad RefWorks Citation Manager  
    Google Docs RefWorks for Google Docs  

    Save to RefWorks

    Save to RefWorks is a bookmarklet that you can install in your browser's favorites (bookmarks) bar. When you are browsing a web site that has references or citations that you would like to add as references to your RefWorks account, select the bookmarklet. RefWorks attempts to save the references and full texts.

    Save to RefWorks should work on any modern browser.

    Installing Save to RefWorks

    To install Save to RefWorks:
    1. Ensure that your browser's favorites toolbar is currently visible in your browser.
    2. In RefWorks, select Tools > Tools. The Tools page appears.
    3. Select Install Save to RefWorks. A dialog box appears.
    4. Drag and drop the Save to RefWorks plugin to your browser's favorites toolbar. The plugin is installed.
    5. Click anywhere on the page to close the dialog box.

    If you experience any problems, see Getting Help / Submitting Ideas to Ex Libris.

    Adding References Using Save to RefWorks

    To add a citation or a reference, or a list of references, on a web site to RefWorks:
    1. Ensure that you are logged into RefWorks.
    2. While browsing any website, when viewing a page containing a citation, or information about a citation, select Save to RefWorks in your browser's favorites toolbar. Save to RefWorks opens a right sidebar.

      save_to_refworks_pane.png

      Save to RefWorks Right Sidebar
      • If Save to RefWorks detects a single citation on the page, Save to RefWorks prefills as many fields as it can. Enter or correct as much information as required and select Save to RefWorks. The reference is added to RefWorks.
      • If Save to RefWorks detects multiple citations, a list of citations appears in the right sidebar. Select the relevant citations and select Save to RefWorks. You can edit each one by first opening the citation (select > in the citation row) .

    Write N Cite

    Write N Cite is a plugin for Microsoft Word that lets you run a simplified version of RefWorks inside of Word. Write N Cite enables you to access and cite your references while working in Word, even if you are currently offline.

    Features:

    • Provides read-only access to your RefWorks account, enabling you to view and insert your previously collated references into your document, formatted using your previously defined citation styles.
    • Uses codes to represent your references and bibliography entries. This enables Write N Cite to manage and update these entities. You can use Write N Cite to manage only the codes that it adds to your document; you cannot manage references added as plain text. Codes appear as plain text when viewing (codes are surrounded by light square brackets) or printing the document.
    • You can add references in-line with the text, as a note, or as a footnote. You can also add an entire bibliography.
    • Enables you to bulk switch and format all entities managed by Write N Cite.
    • Every time you log in to Write N Cite, Write N Cite automatically synchronizes its information with your RefWorks account.
    • Write N Cite works on older versions of Word that are incompatible with RefWorks Citation Manager.
      • Windows users of Microsoft Office 2016 users can choose whether to use Write N Cite or RefWorks Citation Manager.
      • Macintosh users of Microsoft Office 2016 must use RefWorks Citation Manager.
    • Codes inserted by Write N Cite are not recognized by RefWorks Citation Manager, and vice versa.
    • Write N Cite provides only limited access to your RefWorks database, and does not enable you to make any changes to your references.
    • If you have documents with codes that were added using Write N Cite associated with legacy RefWorks, Write N Cite can convert these codes to new RefWorks. Write N Cite cannot otherwise manage older codes.

    Installing Write N Cite

    Requirements

    Write-N-Cite 4.5.1725 for Windows requires the following:

    • Microsoft Word 2010, 2013 (local installation only), or 2016. Write-N-Cite for Windows works best with Word 2013 and 2016 (32 bit versions).
    • Microsoft Windows 7, 8, or 10

    Write-N-Cite 4.5.1765 for Macintosh requires the following:

    • Microsoft Word for Mac 2008 or 2011
    • Mac OS X version 10.6, 10.7, 10.8, 10.9, 10.10, or 10.11 (Snow Leopard, Lion, Mountain Lion, Mavericks, Yosemite, El Capitan) + Sierra 10.12

    In addition, Write N Cite requires:

    • Your operating system and Microsoft Office must be up to date.
    • .NET 4 (Microsoft .NET Framework 4).
    • Visual Studio 2010 Tools for Office Runtime (Visual Studio 2010 Tools for Office Runtime).
    • The latest Java release. Note that when installing Java, you must not install the Ask.com browser toolbar. If you have installed the toolbar, you must remove it.
    • Administrator rights on your computer.

    Downloading and Installing Write-N-Cite

    1. In RefWorks, select Tools > Tools. The Tools page appears.
    2. In the Cite in Microsoft Word area, select Download & Install to download the latest version or Other Windows and Mac Versions to download other versions. If you select Download & Install, the download starts. If you select Other Windows and Mac Versions, the Write N Cite for Word Download Page appears. Select the relevant version and select Download & Install to start the download.

      write_n_cite_download_page.png

      Write N Cite for Word Download Page
      The available options depend on your operating system.
    3. Start the installation and follow any on-screen instructions. After installing the plugin, a RefWorks ribbon appears in Microsoft Word.

      Using-Write-N-Cite-with-Microsoft-Word-Guide-image3.jpg

      RefWorks Ribbon
    4. In Microsoft Word, select Log In in this ribbon to log in to RefWorks. If single sign-on is enabled for your institution, follow the on-screen instructions to log in using single sign-on. Synchronizing data with your RefWorks account may take a few moments, especially on your first login.
      If you are using Write N Cite on a public computer, log out of Write N Cite when you complete your work. However, note that Write N Cite provides only read-only access to your RefWorks database, and does not enable you, or any other user, to make any changes to your references.
    5. To select the format to apply to all Write N Cite managed entities in your document, select Style > [style name].

    If you experience any problems, see Getting Help / Submitting Ideas to Ex Libris.

    Using Write N Cite

    When you open Microsoft Word, if you did not log out after your last session, you are still logged in. If not, select Log In in the RefWorks ribbon to log in to RefWorks. If someone else was logged in to this instance of Word, select Switch Accounts to log out and log back in to your account.

    • If you need to reformat all of your entities for some reason, select Reapply Output Styles. For example, this may be useful when working with master and sub documents that have different citation styles.
    • To manually force a synchronization, select Sync My Database.
    • To convert all of references to plain text select Remove Field Codes.
      If you intend to continue using Write N Cite to manage references in this document, we strongly recommend that you save a copy of your document before doing this, as it cannot be undone.
    To add/edit a reference in-line with the text, as a note, or as a footnote:
    1. To create a reference, select Insert Citation > Insert New. To edit a reference, double-click the reference. In either case, the Insert/Edit Citation pane appears.

      Using-Write-N-Cite-with-Microsoft-Word-Guide-image9.jpg

      Insert/Edit Citation
    2. Use the folders and the search bar to locate the citation. You can right-click the reference to see complete reference information.

      Using-Write-N-Cite-with-Microsoft-Word-Guide-image11.jpg

      Full Reference View
    3. Select the reference. A preview of the formatted reference appears in the Preview Citation area. Optionally select + in the Compose Citations area to add additional references.
    4. Optional: To make the reference a footnote, instead of in-text, select Make Footnote. Unlike other configuration options (see next step), this cannot be undone once you save the reference.
    5. Optional: You can configure any of the following while creating or editing a reference:
      • Hide the publication year
      • Hide the author name
      • Add text before the reference (Prefix)
      • Add text after the reference (Suffix)
      • Hide the reference and only have the bibliography entry
      • Hide page numbers (Suppress Pages)
      • Add page numbers (Override Pages)
      • Change the reference order: Use the up or down arrows for styles that use first-cited order. For styles that use alphabetical or other sorting, select Override Default Ordering.
        Some options depend on your citation style. For example, adding or hiding page numbers works only if your citation style has page numbers.
    6. Select OK to insert or save the selected references. Different formats apply depending on whether you add the reference in-text, as a note, or as a footnote.
    To insert a bibliography:

    To insert a bibliography that includes all Write N Cite managed entities in your document, select Bibliography Options > Insert Bibliography.

    RefWorks Citation Manager

    RefWorks Citation Manager is a plugin for Microsoft Word that lets you run a simplified version of RefWorks inside of Word. RefWorks Citation Manager enables you to access and cite your references while working in Word, even if you are currently offline. RefWorks Citation Manager is a newer, more modern version of Write N Cite.

    RefWorks Citation Manager is available through the Microsoft Store and can be installed directly from Microsoft Word. By default, Office automatically updates RefWorks Citation Manager whenever a new version becomes available.

    Features:

    • Provides read-only access to your RefWorks account, enabling you to view and insert your previously collated references into your document, formatted using your previously defined citation styles.
    • Uses codes to represent your references and bibliography entries. This enables RefWorks Citation Manager to manage and update these entities. You can use RefWorks Citation Manager to manage the codes that it adds to your document; you cannot manage references added as plain text. Codes appear as plain text when viewing (codes are surrounded by light square brackets) or printing the document.
    • You can add references in-line with the text or as a footnote. Adding a reference also adds a bibliography to the end of the document. As you add or remove references, the plugin automatically updates the bibliography.
    • Enables you to bulk switch and format all entities managed by RefWorks Citation Manager.
    • Every time you log in to RefWorks Citation Manager, RefWorks Citation Manager automatically synchronizes its information with your RefWorks account.
    • Windows users of Microsoft Office 2016 users can choose whether to use Write N Cite or RefWorks Citation Manager. Macintosh users of Microsoft Office 2016 must use RefWorks Citation Manager.
    • Codes inserted by Write N Cite are not recognized by RefWorks Citation Manager, and vice versa.
    • RefWorks Citation Manager provides only limited access to your RefWorks database, and does not enable you to make any changes to your references.
    • If you have documents with codes that were added using RefWork Citation Manager associated with legacy RefWorks, RefWorks Citation Manager can convert these codes to new RefWorks. RefWorks Citation Manager cannot otherwise manage older codes.

    Installing RefWorks for Citation Manager

    Requirements

    RefWorks Citation Manager can run on any of the following applications:

    • Microsoft Word for Windows 2016
    • Microsoft Word for Mac 2016
    • Microsoft Word for iPad
    You do not need administrator access to install RefWorks Citation Manager.

    Installing RefWorks Citation Manager

    1. In Microsoft Word, select Insert > Store and search for refworks or proquest.

      RefWorks-Citation-Manager-image1.jpg

    2. Select Add in the row for RefWorks Citation Manager. Reference Citation Manager is installed and opens in the right sidebar.
      If you close the sidebar, you can redisplay it by selecting Insert > My Add-ins > RefWorks Citation Manager.

      RefWorks-Citation-Manager-image2.jpg

      RefWorks Citation Manager - Not Logged In
    3. Log in to RefWorks. If single sign-on is enabled for your institution, follow the on-screen instructions to log in using single sign-on. Synchronizing data with your RefWorks account may take a few moments, especially on your first login. Once you are logged in, the sidebar updates with your references.

      If someone else was logged in to this instance of Word, select Log Out in the action menu and log back in to your account.

      RefWorks-Citation-Manager-image3.jpg

      RefWorks Citation Manager - Logged In

      An action menu is available on the left of the sidebar. In addition, a configuration menu is available when you select the top right of the sidebar.

      refworks_citation_manager_configure_icon.png

      Action and Configuration Menu Icons
    4. To set the style for all citations, select Change citation style in the action menu. A dialog box appears in the right sidebar. Select the style (defined in RefWorks) and select Update. Every time you perform this action, all references in the document, and the bibliography, update to the new style.

    If you experience any problems, see Getting Help / Submitting Ideas to Ex Libris.

    Using RefWorks Citation Manager

    To insert a reference as text:

    Select the reference and select Quick Cite. When you do, two things are added to your document:

    • Text is inserted directly into the document.
    • A bibliography of references is created at the end of the document. If the bibliography already exists, the reference is added to it.
    To configure the reference before inserting it (or to add it as a footnote):
    1. Select the reference and select Preview & Edit. The Preview & Edit pane appears. Full reference information is at the bottom of the pane.

      refworks_for_google_docs_edit_citation.png

      Preview & Edit
    2. Select whether to insert the reference in-text or as a footnote.
    3. Optionally configure whether to change the page numbers, hide the author, or hide the publication year. A preview of both the text and the bibliography reference appears in the pane.
    4. Optionally add a prefix or suffix text to the reference.
    5. Select Insert Citation. The reference is added as a block element and an entry for the reference is added to the bibliography.

    Additional actions:

    • Edit a reference – Move your cursor to anywhere in the reference. The reference information opens in the right sidebar.
    • Delete a reference – Select the entire reference, either by highlighting with your mouse or by selecting the block element handle (see figure) and press Delete. Then select Update document in the action menu to update the bibliography.
    • Format for footnotes – Select to pre-select the Footnote option for adding references.
    • Refresh RefWorks – If for some reason you need to refresh the RefWorks pane, select Reload in the configuration menu.
    • View Source – For support use.
    • Security Info – Microsoft information about the plugin.

    To get help, select Ex Libris Knowledge Center in the action menu or Get Support in the configuration menu.

    RefWorks for Google Docs

    RefWorks for Google Docs is a plugin for Google Docs that lets you run a simplified version of RefWorks inside of Google Docs. RefWorks for Google Docs enables you to access and cite your references while working in Google Docs.

    Features:

    • Provides read-only access to your RefWorks account, enabling you to view and insert your previously collated references into your document, formatted using your previously defined citation styles.
    • You can add references in-line with the text or as a footnote. Adding a reference also adds a bibliography to the end of the document. As you add or remove references, the plugin automatically updates the bibliography.
    • When you share your document with another user who is using RefWorks for Google Docs, they can edit and delete any RefWorks references in the document and can add their own references to the document.
    • Every time you log in to RefWorks for Google Docs, RefWorks for Google Docs automatically synchronizes its information with your RefWorks account.

    Installing RefWorks for Google Docs

    1. Open a blank document and select Add-ons > Get Add-ons and search for refworks or proquest.

      Writing-Your-Paper-with-the-RefWorks-for-Google-Docs-Add-on-image1.jpg

      Google Docs Add-Ons
    2. Select Free and Allow to add RefWorks for Google Docs.
    3. Select Add-ons > ProQuest RefWorks > Manage citations. A RefWorks sidebar opens on the right of Google Docs.

      refworks_for_google_docs_not_logged_in.png

      RefWorks for Google Docs - Not Logged In
    4. Whenever you open the sidebar, if you did not log out after your last session, you are still logged in. If you are not logged in, enter your credentials to log in to RefWorks. Your references appear in the sidebar.

      refworks_for_google_docs_not_logged_in.png

      RefWorks for Google Docs - Logged In
    5. To configure the default output style, select Change citation style in the configuration menu, select a citation style (pre-configured in your RefWorks account), and select Update. Every time you perform this action, all references in the document, and the bibliography, update to the new style.

    If you experience any problems, see Getting Help / Submitting Ideas to Ex Libris.

    Using RefWorks for Google Docs

    To insert a reference in-text:

    Select the reference and select CIte this. When you do, two things are added to your document:

    • Text is inserted directly into the document.
    • A bibliography of references is created at the end of the document. If the bibliography already exists, the reference is added to it.

    If you delete a reference, select Update document from the configuration menu. Your document refreshes and the deleted reference is removed from your bibliography.

    To configure the reference before inserting it:
    1. Select the reference and select Edit and Cite. The Edit Citation pane appears.

      refworks_for_google_docs_edit_citation.png

      Edit Citation
    2. Optionally configure the citation style, and whether to add page numbers, hide the author, or hide the publication year. A preview of both the text and the bibliography reference appears in the pane.
    3. Select Insert.
    • Was this article helpful?