Skip to main content
ExLibris
  • Subscribe by RSS
  • Ex Libris Knowledge Center

    Network-Managed Records in a Network Zone

    Translatable
    When working at a member institution in a collaborative network, you can manage bibliographic and authority records at either the institution or network level.
    • When you create or import a new record (through various procedures), you can select to manage the record in the institution or the network. An administrator can restrict records to be managed only in the network.
    • You can copy (share) local records to network records, which creates the network-managed record and links the local record to it. Before creating the record, Alma tries to match an existing network-managed record. You can also link a local record to an existing network-managed record. And you can copy (without linking) Community Zone records to create network-managed records.
      Changes made to linked network records are automatically reflected in local records. You can view information on activity related to linked records in a report.
    • Similarly, you can copy records from the network to the institution, either creating new, unlinked local records or new, linked local records linked to the network-managed record.
    • You can add local extensions to records managed at the network level. In this way, some of the record's information is only visible at the local institution. Adding extensions to a network record automatically creates a local, linked record.
    • A repository search can be performed over institution, community, or network records. You can configure inventory management groups to restrict access to electronic resources by institution, in addition to the usual restrictions by library. See Repository Search in a Collaborative Network.
    • Inventory management groups can be used to restrict or enable access to inventory by institution. For more information, see Configuring Distributed Access to Electronic Resources When Working with a Network Zone.

    Selecting Where to Create New Bibliographic Records

    There are several locations in Alma at which you have the option to create or save a new or imported record to the local institution or to the Network Zone. These locations are listed in this section.
    An administrator working in a member institution can configure the parameter central_record_management to change which of these options is selected by default (DEFAULT_INSTITUTION or DEFAULT_NETWORK) or to disable the ability to add records to the local institution (ENFORCE_NETWORK). For more information, see the parameter in Configuring Other Settings.
    The following locations are used to create or save a new network record:
    • Importing records: When configuring a Repository type import profile, select Use Network Zone to import records to the Network Zone. When central_record_management is set to ENFORCE_NETWORK, Use Network Zone is set to yes and cannot be changed.
      Import Profile Details
      Similarly, when selecting what to do when there is no match for a record, in addition to the usual options Do Not Import and Import (to the institution), you can select Add to NZ to import the record to the Network Zone. For more information, see Managing Import Profiles.
      The procedure is similar when importing records using a Patron-Driven Acquisitions (PDA) load file. For more information, see Patron Driven Acquisitions.
    • Similarly, when importing records by creating an OCLC Connextion integration profile. See Importing Records from OCLC Connexion.
      In the OCLC Connextion integration profile, the Use Network Zone record option is used upon finding a match. Due to a technical limitation, currently you cannot select the Merge, Overlay, or Do not import options.
    • Creating a new bibliographic record: In the MD editor, select Network for the Placement of new records and templates parameter (File > Options) to add a new record as a network-managed record; see Navigating the MD Editor Page. (The option Network may appear as something else if an administrator configures the network_label parameter; see Configuring Other Settings.) When central_record_management is set to ENFORCE_NETWORK, the Placement of new records and templates parameter is disabled and defaults to Network.
      MD_Editor_File_Options.png
      MD Editor File > Options Dialog Box
    • Manually adding a portfolio/physical item/digital representation: The field Placement of new record appears on the relevant page for adding the item's details. Select Network to create the record in the Network Zone. (The label Network may appear as something else by configuring the network_label parameter; see Configuring Other Settings.) When central_record_management is set to ENFORCE_NETWORK, Placement of new record is disabled and defaults to Network.
      New Portfolio Page
    • Adding portfolios using the portfolio loader: In the Bibliographic area of the activation wizard, in the Select catalog field select Network to create bibliographic records for the portfolios in the Network Zone. When central_record_management is set to ENFORCE_NETWORK, Select catalog is disabled and defaults to Network.
      Activation Wizard: File Upload Page
      If no match is found in the Network Zone, the record is added to the Network Zone and the portfolio is linked to the record. When a single bibliographic record match is found in the Network Zone, a link to that record is created. When multiple matches are found in the Network Zone, no record is created and manual handling may be required. For more information see Adding, Updating, or Removing Local Portfolios in Bulk Using an Excel File.

    Working with Validation Exception Profiles in the Network

    See Working with Validation Exception Profiles for information about working with and configuring the validation exception profiles and refer to the following section for details specific to a Collaborative Network.

    Working with Normalization Rules in the Network

    Local fields added to a record using Add Local Field from a member institution can be updated or deleted using normalization rules. For details, see Managing Local Fields Using a MARC 21 Bib Normalization Job below. For network-managed records, normalization rules run only on the shared data fields.
    See Working with Normalization Rules for more information.

    Preventing the Addition of Local Fields to Network Zone Records

    By default, when you manually add local fields to Network Zone records using the MD Editor, a warning message appears (not an error message). However, with the Validation Exception Profile, you can configure Alma to prevent these additions and display an error message instead of a warning message.
    To configure Alma to not save local changes to Network Zone records:
    This configuration should be completed in the Network Zone.
    1. On the Metadata Configuration List page (see Configuring Cataloging), select the MARC 21 Bibliographic link in the Profile column.
    2. Select the Validation Exception Profile List tab.
    3. Select Actions > Edit for the MARC XML Bib Metadata Editing On Save profile.
    4. On the Validation Severity Profile Exceptions page, select Local field cannot be added on network record in the Add Validation Severity Exception section, and select Add Validation Severity Exception.
    After you complete the Validation Exception Profile changes and a user attempts to add local fields to a Network Zone record, the user is prevented from saving the record and an error message appears on the Alerts tab.

    Copying and/or Linking Local and Network Zone Bibliographic Records

    Before contributing a local bibliographic record to the Network Zone, you can choose to validate changes to the record based on the Network Zone's validation routines (see Editing Validation Routines). You can link local records to Network Zone records individually or in bulk. When linking local records individually, note that for your changes to take effect, you must save the record.
    To validate a record before copying it to the Network Zone:
    When editing a local record in the MD editor, select Tools > Validate in Network Zone. This works similar to validating the record in the local institution (Tools > Validate), but the validation is performed against the Network's Zone's validation routines.
    To link existing local records to (and possibly create) Network Zone records:
    When editing a local record in the MD editor, select File > Share With Network. If central_record_management is set to ENFORCE_NETWORK (see Configuring Other Settings), the Share With Network option does not appear for most records. This option continues to appear for migrated records that are not yet part of the Network Zone.
    If a match is found in the Network Zone, you can preview the match or select from among multiple matches; select Link beneath the desired matching record to link the institution record to the existing Network Zone record. If no matches are found, the institution record is linked to a new Network Zone record.
    Sometimes, the Share with Network functionality may fail if the configuration settings differ between the Network Zone and the institution. You must choose the same match profile for both the Network Zone and the institution. See Match Methods - Explanations and Examples.
    To view the version of the record before you linked it to the Network Zone, select Tools > View Versions of Original Record.
    To link existing local records to Network Zone records in bulk, run the Link a set of records to the Network Zone job. For more information, see Link a Set of Records to the Network Zone on the Running Manual Jobs on Defined Sets page.
    To create new local records linked to existing Network Zone records:
    • When creating a new local portfolio, select Use existing title for Creation Type. The Placement of new record field is removed from the page. Use the Choose Title field to select a record in the Network Zone (or Community Zone). Selecting a Network Zone record creates a new institution record linked to the Network Zone record.
    • When creating a new local digital representation, select Existing and use the Title field to select a record in the Network Zone.
    • When creating a physical item, select Existing in the Choose Holding Type dialog box and then use the Title field in the Quick Cataloging page to select a record in the Network Zone.
    To copy Network Zone records to local records (without linking the records), or to unlink local and Network Zone records:
    When editing a Network Zone record or a linked record in the MD Editor, select File > Copy to Catalog. The result is an unlinked local copy of the record and a Network Zone copy of the record.
    To copy Community Zone records to new Network Zone records (without linking the records):
    In the simple Record View page for a Community Zone record (perform an All Titles search in the Community Zone and select the record title), select Copy to Network to copy the record to the Network Zone.

    Adding Local Extensions to Bibliographic Records in the Network Zone

    • Catalog Operator
    • Catalog Manager
    You can add and edit local extensions to a bibliographic record that is maintained in the Network Zone. Local extensions provide a place for you to enter local information and, at the same time, maintain the integrity to the original and ongoing updated versions of the Network Zone record for other Network Zone members.
    Specifically, you can enter local information in the MARC 21 77X/78X, 09X, 59X, 69X, and 9XX fields. Local information should be added using the Add Local Field option in the MD Editor, as described in Adding Local Extensions Using the MD Editor below.
    For network members using UNIMARC metadata, local extensions are supported for the UNIMARC X9X, XX9, and 9XX fields.
    • Only one metadata format at a time per network is supported for local extensions. That is, a network’s members can work with UNIMARC local extensions or MARC 21 local extensions, but not both.
    • When a member edits a Network Zone record, the controlled vocabulary that is used is from the Network-configured controlled vocabulary (not the member-configured controlled vocabulary).

    Adding Local Extensions Using the MD Editor

    When you are working in the MD Editor, local fields for Network Zone records are identified by the library icon.
    To add a local field to a Network Zone record using the MD Editor:
    1. Open a Network Zone record in the MD Editor.
    2. Select Edit > Add Local Extension to enter a local field (see above for supported MARC 21/UNIMARC local fields).
      59X Field Added as a Local Field
    The local field is added and is visible only to the member institution and not to other institutions.
    A local field should not be added to the Network Zone record using the Edit > Add Field function. In fact, Alma should be configured to prevent this situation from occurring. For details, see Preventing the Addition of Local Fields to Network Zone Records. Only the Edit > Add Local Extension function should be used to add a local field. 

    Managing Local Fields Using a MARC 21 Bib Normalization Job

    You can use the MARC 21 Bib Normalization job to normalize Network Zone-linked records that contain local fields such as the 9XX fields. This job makes changes (add, update, or delete) only to the local fields and saves them to the Institution Zone. Since these are local changes, they are not distributed to the Network Zone or other members.
    This feature extends the functionality of the normalization drool (part of a normalization process) for records that are linked to the Network Zone. The normalization processes can be accessed/added on the Normalization Processes tab of the Profile Details page (see Configuring Cataloging)..
    Normalization Tab for MARC 21 Bibliographic Processes
    To run a batch job to make global changes on local extensions on Network Zone-linked records:
    1. Create a normalization rule to be selected for the Drools File Key parameter in the next steps. See To create a new normalization rule file in Working with Normalization Rules.
    2. Create a normalization process for the purpose of adding local extensions to Network Zone-linked records. See To add a process in Working with Normalization Processes
    3. Create/save the set of records to be updated.
    4. Run a normalization job. The job’s name is based on a normalization process that you created and appears in the list of manual jobs that you can run on defined sets. For more information, see Running Manual Jobs on Defined Sets.

    Harvesting Community Zone Linked Electronic Records

    With the Import CZ Records from CN/NZ Members Task job, you can Harvest Community Zone linked electronic records from members in a Network Zone and display these records in the Network Zone as linked to the Community Zone. See Import CZ Records from CN/NZ Members Task for more information.

    The Network Harvesting Report

    Institution bibliographic records that are linked to Network Zone records are automatically updated with any modifications that take place in the Network Zone. Alma provides a detailed Network Harvesting report that displays a list of all updates, deletions (that is, links to the resource that were deleted), and errors for these records.
    The Network Harvesting report (Resource Management > Manage Inventory > Network Harvesting Report List) is available to all network member institutions and is refreshed every five minutes. It contains the following information for each resource:
    • Resource ID
    • Type of operation in the network (update, deletion, error)
    • ID of the member institution that performed the operation
    • Date of the operation

    Creating Templates in the Network Zone

    GND and BARE

    Templates created in the Network Zone for GND and BARE automatically appear in the Templates list of member institutions, and they are identified with the Network Zone icon. For example, to create an authority record template in the Network Zone, open the MD Editor and create an authority record with the fields you want and select Save as Template. The template you saved appears under the Templates tab in the Network Zone and in the member institutions. In the Network Zone, the template appears with the local institution icon; and in the member institutions, the same template appears with the Network Zone icon. For more information about creating templates, see Working with Record Templates.

    Other Authority Templates

    Other templates created in the Network for locally-managed authority records (such as LC Name, LC Subject, and so forth) are automatically available to member institutions that work with the same local authority records. In the member institution Templates list, an additional folder by the same name with (Network) appended to the name contains the Network-created templates in the Shared folder along with the out-of-the-box templates that are provided in the Shared folder.
    Network_Managed_Templates_Available_to_the_Member_Institution_02_TC.png
    Network Managed Templates Available to the Member Institution
    The templates continue to be created in the same manner in the Network with different icons representing the out-of-the-box templates from the templates created locally in the Network.
    Locally_Created_Templates_in_the_Network_02_TC.png
    Locally Created Templates in the Network
    For more information about creating templates, see Working with Record Templates.